Support » Plugin: A-Z Listing » Letters not showing horizontally

  • swedish62

    (@swedish62)


    I have an issue with that the letters in my index are shown in one vertical line, instead of horizontally. Strangely, it looks correct on my own laptop, but wrong everywhere else. Link to the index

    Any thoughts on this?

    • This topic was modified 4 months ago by swedish62.

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 23 total)
  • Plugin Author Daniel Llewellyn

    (@diddledan)

    Hi,

    As it shows correctly when you are logged-in then I suspect that the problem is server-side caching of public anonymous page views. Try to find a cache clear/purge facility on your server to see if clearing the caches fixes it up.

    swedish62

    (@swedish62)

    Hi,
    Do you mean the admin area of my blog? I cleared the cache there a few times. Or rather with my web host?

    I still don’t understand what you mean. Do you have a solution for this?

    Plugin Author Daniel Llewellyn

    (@diddledan)

    You are using autoptimize to bundle your stylesheets and javascript. Try clearing the cache that it generates.

    I cleared the cache numerous times but it’s still the same. Also I had your plugin before I had autoptomize. As I said, it looks correct for me when I’m logged in, but wrong for everyone else.

    And it looks wrong both in the index and the sidebar.

    Plugin Author Daniel Llewellyn

    (@diddledan)

    As it shows correctly when you are logged-in you need to find out what is different between the logged-in and logged-out page content to narrow down why it’s failing.

    Try disabling all other plugins temporarily and switch to a default twenty-something theme. This will help us to identify if another plugin or your theme is conflicting.

    pro-tip; you can disable Autoptimize on a per-request basis by adding ?ao_noptimize=1 to the URL.

    if the problem is not there at that point, some autoptimize (re-)configuration might be needed to fix this. there are troubleshooting tips and info on how to exclude in the AO FAQ.

    hope this helps debugging,
    frank (ao dev)

    I have 2017 right now. If I disable all the plugins that will ruin some functions no?

    Thanks for the tip, Optimizing Matters, but I think it looked the same even before I had autoptomize. In any case, I’m not sure I know how to do that. Which URL are you referring to?

    You mean I should add the code above to the index URL slug?

    I mean try https://www.disapprovingswede.com/?ao_noptimize=1 , if the problem persists then you can be sure it is not due to Autoptimize indeed, one thing to strike from the list 😉

    That was for the main page. When I click on the index it still looks the same. I also added the code after the index page, but still the same in incognito mode.

    Obviously, I appreciate all input on the topic.

    swedish62

    (@swedish62)

    So I made screenshots of everything that is loading on the page I use for your index. It seems there is no way to post screenshots here though. These could be disabled in the script manager

    So, anyway what loads is the following:

    Autoptimize
    Flying Pages by WP Speed Matters
    Mashshare Share Buttons
    Modern Footnotes
    WP Sticky Sidebar
    Rank Math SEO
    WP Google Search
    Gutenberg
    Plugin Detective – Troubleshooting
    WPForms Lite

    THEMES
    Twenty Seventeen

    And then some misc stuff. Each headline has more detailed info with things that could be turned off. I just thought I would ask, before starting turning things off at random.
    Some things like the sidebar are not even used on the index page so maybe I could start with that one? Any input would be appreciated.

Viewing 15 replies - 1 through 15 (of 23 total)
  • You must be logged in to reply to this topic.