Support » Plugin: LearnPress - WordPress LMS Plugin » Lessons are not loaded

  • Hello, I downloaded version 2.1.6, I installed and setup correctly. But when you want to see the lessons are not loaded, i only see the loading icon.

    Help me!
    Thanks.

Viewing 13 replies - 1 through 13 (of 13 total)
  • Electra

    (@electrakittie)

    Me too, I create the course, but not loading the quizzes… :c VER LEARNPRESS: 2.1.6.1, PHP 7.1, WORDPRESS 4.7.4

    • This reply was modified 5 years, 3 months ago by Electra.

    what is happening – why are you ignoring this issue?

    Plugin Contributor Ken Nguyen

    (@kendy73)

    Hi guys,

    I am so sorry for my late response. I missed it.

    There are some reasons might cause the pop-up process. Please help me to check:

    1. Permalink settings:
    + Please go to menu Settings / Permalinks. I recommend using Post Name option.

    2. A JS conflict.
    + Please open the lesson URL.
    + Turn on console to check if any bugs occur then give us a sreenshot about it. This guideline will be helpful to you https://codex.wordpress.org/Using_Your_Browser_to_Diagnose_JavaScript_Errors.

    Please check all those things and give me some more extra info. We will solve the issue together.

    Regards,

    Ken

    I have no problems adding a lesson to a course but when I save the course, the lesson just disappears.
    Will you please advise where I can send login details as I need you to look at this urgently. My customer is shouting at me because if this issue.

    Geoff

    Plugin Contributor Ken Nguyen

    (@kendy73)

    Geoff, do you add any lessons/quizzes before?

    Please try with add new item and add existed item, then let me know more details about what happens. A screenshot about your curriculum will help a lot.

    Regards,

    Ken

    Yes – of course I have added lessons and quizzes. When I select one to add to a course, it shows but when I save the course the lesson disappears. Also I cannot give a course section a name as it also disappears.

    Please – where can I send WP login details so that you can see this happening?

    Geoff

    Plugin Contributor Ken Nguyen

    (@kendy73)

    Okay. You can reach me at candy@thimpress.com.

    Ken – this is becoming serious now. I have given you all required access details. Will you please advise what is happening!!

    Plugin Contributor Ken Nguyen

    (@kendy73)

    I found out the reason why. A conflict with SiteOrigin page builder. But will need some more time to solve it. Please temporary deactivate Page Builder mode in courses.

    This conflict occurred with the newest version of SiteOrigin. The older version still works fine.

    Just give me some more time.

    Regards,

    Ken

    Ken – I have now started adding lessons to courses with Site origin disabled. However when I try to view the course I get a 4094 error so I dont want to waste any more time on this until its fixed.

    Please – how long?

    Geoff

    Plugin Contributor Ken Nguyen

    (@kendy73)

    I see those courses are okay now.

    I recommend you to update the theme to newest versions too. You can find the instruction for the update here https://thimpress.com/knowledge-base/update-theme/

    Hi
    I have installed Learnpress 2.1.6.1 and am running WP 4.7.4 with Terrifico theme. Our lessons are not loading in Google Chrome – they are loading when we check the same page on Internet explorer.

    The following error appears on Google Chrome console:

    Uncaught TypeError: Cannot read property ‘top’ of undefined
    at a.fn.init.$.fn.stickUp (stickUp.js:65)
    at HTMLDocument.<anonymous> (sticky.js?ver=4.7.4:4)
    at i (jquery.js:2)
    at Object.fireWith [as resolveWith] (jquery.js:2)
    at Function.ready (jquery.js:2)
    at HTMLDocument.K (jquery.js:2)

    Script Debug in wp-config.php did not fix the issue.

    Please let me know what I need to do in order to fix this issue.
    Thanks

    Hi lesstead,

    Please give us some screenshot.

    Regards,

    Hien Phan.

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘Lessons are not loaded’ is closed to new replies.