Support » Plugin: Antispam Bee » Legitimate comments marked as spam

  • Resolved loythegreat

    (@loythegreat)


    Antispam Bee used to work without problems. But in the past few days, all legitimate comments from my readers are marked as spam and deleted. I selected all fields in “Delete comments by spam reasons” but the culprit seems to be the Honeypot. If I deselected Honeypot, the comments will not be deleted, but spam comments will go to the spam folder. So I think the problem might be the Honeypot.

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Contributor Torsten Landsiedel

    (@zodiac1978)

    Hi @loythegreat

    I selected all fields in “Delete comments by spam reasons”

    I would not recommend to do that as there can be false positives sometimes. “Honeypot” and “Empty fields” should be safe.

    If I deselected Honeypot, the comments will not be deleted, but spam comments will go to the spam folder.

    This looks correct. Spam comment goes to spam folder. But “all legitimate comments from my readers are marked as spam and deleted.” looks not okay.

    If the honeypot is the culprit there needs to be some change in your markup or environment which causes this. Have you installed an update or new plugin just before the problem started?

    Can you provide more information about theme (+ version number) and active plugins? And in the best case, provide the URL, too?

    Then I can have a look and maybe find the problem in the theme, a plugin or in your markup.

    Thanks in advance!

    All the best
    Torsten

    Thread Starter loythegreat

    (@loythegreat)

    Thank you for your response. Can I post my information here?

    I tested the comments with only Honeypot and Empty Data enabled in “Delete comments by spam reason” and sure enough my comment was immediately tagged as spam and deleted.

    If I disable Honeypot and enable the rest, I get spam comments in the Spam folder and legitimate comments are tagged as spam as well.

    I remember I started to use the Ezoic Leap feature around that time. It’s possible that it caused it.

    • This reply was modified 4 months, 1 week ago by loythegreat.
    • This reply was modified 4 months, 1 week ago by loythegreat.
    Plugin Contributor Torsten Landsiedel

    (@zodiac1978)

    Hi @loythegreat

    Can I post my information here?

    Yes, please!

    and legitimate comments are tagged as spam as well.

    Then we should try to find the culprit here.

    I remember I started to use the Ezoic Leap feature around that time.

    Can you post a link to what you have installed. Is it a plugin or a setting within another plugin/theme?

    All the best
    Torsten

    Thread Starter loythegreat

    (@loythegreat)

    I just discovered the reason and it’s the Ezoic plugin. When I disable it, commenting is back to normal.

    I will have to raise this issue with Ezoic.

    Thank you.

    Plugin Contributor Torsten Landsiedel

    (@zodiac1978)

    Hi @loythegreat

    thanks for letting us know!

    If we can help debugging or there needs to be something done on our side to make the plugins compatible, please report back your findings.

    As I don’t have an ezoic login I can’t further test the plugin. Any chance to provide the URL? Then I can at least look if the honeypot is in the markup.

    All the best
    Torsten

    Thread Starter loythegreat

    (@loythegreat)

    Hello Torsten, my website is techpilipinas.com.

    Unfortunately, I cannot remove the Ezoic plugin because it’s required by my ad network so I’ll need to find a way for the two plugins to work together. I will open a support ticket with Ezoic.

    Antispam Bee is the only plugin that prevents spam from flooding my site so I can’t remove it either nor find an alternative.

    Thank you so much for you assistance.

    Plugin Contributor Torsten Landsiedel

    (@zodiac1978)

    Hi @loythegreat

    at the moment the honeypot is not applied to the comment form on the mentioned website.

    Just a quick question: Are you using the Ezoic CDN?

    Please report back if you have feedback from the Ezoic support!

    All the best,
    Torsten

    Plugin Contributor Torsten Landsiedel

    (@zodiac1978)

    Hi @loythegreat

    any news from the Ezoic support?

    I have tracked down the problem to the buffering process.

    Even without the API connection my honeypot is broken after the activation of the plugin.

    After commenting out this line in class-ezoic-integration.php it works again:
    $this->loader->add_action( 'shutdown', $plugin_public, 'ez_buffer_end', 0 );

    We already had one report in this issue:
    https://github.com/pluginkollektiv/antispam-bee/issues/357

    Maybe they can report there any findings.

    All the best
    Torsten

    • This reply was modified 4 months ago by Torsten Landsiedel. Reason: Changed code to one line instead of two lines
    Thread Starter loythegreat

    (@loythegreat)

    Hello Torsten,

    Thank you for the solution. Yes, my site is using the Ezoic CDN.

    I’ve tested your solution and it works. Legitimate comments are no longer tagged as spam even with the honeypot enabled.

    I haven’t actually contacted Ezoic yet about this issue, but I will do it now and point them to this page as well as to the report on Github, so that they can update the plugin.

    Once again thank you and if you accept donations I would be willing to give a little 🙂

    Plugin Contributor Torsten Landsiedel

    (@zodiac1978)

    Hi @loythegreat

    Once again thank you and if you accept donations I would be willing to give a little 🙂

    Yes, there is a “Donate” link on the Plugin page (bottom right):
    https://wordpress.org/plugins/antispam-bee/

    Thanks for taking the time to report the issue and post your findings!

    All the best
    Torsten

    Thread Starter loythegreat

    (@loythegreat)

    Good day!

    I just would like to report that the issue has been resolved after the latest update of the Ezoic plugin. So there’s no need to edit the file anymore.

    Thank you so much!

    Plugin Contributor Torsten Landsiedel

    (@zodiac1978)

    Hi @loythegreat

    Thanks for reporting back! Great to hear that. 🙂

    We have also some ideas on how to resolve such issues in the future.

    If you (or anyone else) want to follow our ideas, here is the PR:
    https://github.com/pluginkollektiv/antispam-bee/pull/392

    All the best
    Torsten

Viewing 12 replies - 1 through 12 (of 12 total)
  • You must be logged in to reply to this topic.