Support » Plugin: Slider, Gallery, and Carousel by MetaSlider - Responsive WordPress Plugin » Left and right arrows close together and inability to make a button.

Viewing 15 replies - 1 through 15 (of 21 total)
  • Thread Starter ildomandatore

    (@ildomandatore)

    I found that the slider has themes and that I can color its button background. The problem remains that I see 3 arrows.
    https://postimg.cc/F1bfNBbX

    Plugin Support Arreane

    (@yanex)

    Hi,

    I went ahead and checked your site and slightly modified the CSS. You can try and paste the following CSS code instead.

    .metaslider.ms-theme-nivo-dark .nivo-directionNav a {
        background: #000 !important;
        bottom: -54px !important;
        height: 44px !important;
        width: 44px !important;
    }
    .metaslider.ms-theme-nivo-dark .nivo-directionNav a:before {
        color: #fff;
        position: absolute;
        text-indent: 0;
        left: 0;
        right: 0;
        top: 0;
        bottom: 0;
        align-items: center;
        display: flex;
        justify-content: center;
    }
    .metaslider.ms-theme-nivo-dark .nivo-directionNav a.nivo-prevNav:before {
        content: '<';
    }
    .metaslider.ms-theme-nivo-dark .nivo-directionNav a.nivo-nextNav:before {
        content: '>';
    }
    Thread Starter ildomandatore

    (@ildomandatore)

    I don’t see the changes. The first code is like mine, the others don’t work. I cleared the cache and went on anonymous browsing, but nothing to do.

    Plugin Support Arreane

    (@yanex)

    Hi,

    Please make sure that you have added the CSS code correctly.

    Here’s a short recording showing that the code I provided works – https://share.getcloudapp.com/bLudeKJD

    Thread Starter ildomandatore

    (@ildomandatore)

    Plugin Support Arreane

    (@yanex)

    Your site clearly didn’t register your code. If you have a caching plugins, please try to flush/deactivate it.

    The code I provided does work. It just missing the code in the :before pseudo class. https://share.getcloudapp.com/kpu65PqN

    You can verify if your css changes reflect or not on your source code – view-source:https://oldfreegame.com/en/

    Thread Starter ildomandatore

    (@ildomandatore)

    it’s like before. Black background, no content. I can’t read the source code, I’m a beginner.

    Plugin Support Arreane

    (@yanex)

    This is what’s missing on your CSS code. Can you try adding on the first line of your css code and see if the code registers?
    .metaslider.ms-theme-nivo-dark .nivo-directionNav a.nivo-prevNav:before {
    content: ‘<‘ !important;
    }
    .metaslider.ms-theme-nivo-dark .nivo-directionNav a.nivo-nextNav:before {
    content: ‘>’ !important;
    }

    Thread Starter ildomandatore

    (@ildomandatore)

    Plugin Support Arreane

    (@yanex)

    Looks like your CSS code ‘<‘ and ‘>’ gets rendered into a character code. You can try and use a plugin like Simple Custom CSS and JS to add your CSS code.

    Thread Starter ildomandatore

    (@ildomandatore)

    I make other attempts. Tell me how it should be written and its variant.

    Plugin Support Arreane

    (@yanex)

    Instead of adding the code below to Appearance > Customize > Additional CSS.

    Try installing a plugin that would help you embed your CSS code and paste the code below.

    .metaslider.ms-theme-nivo-dark .nivo-directionNav a.nivo-prevNav:before {
    content: ‘<‘ !important;
    }
    .metaslider.ms-theme-nivo-dark .nivo-directionNav a.nivo-nextNav:before {
    content: ‘>’ !important;
    }
    Thread Starter ildomandatore

    (@ildomandatore)

    I tried with Code Snippet and got a fatal error. Would the Simple Custom CSS and JS plugin be a similar plugin with each other or is it something else entirely?

    Thread Starter ildomandatore

    (@ildomandatore)

    I disabled all plugins with Health Check & Troubleshooting except Metaslider and Elementor.
    https://drive.google.com/file/d/1gn_icT3Ai-uoO083wc_IfDEEIclhMTe6/view?usp=sharing

    Without Elementor, I don’t see the slider. I keep having frequent problems with Metaslider modifications. I cleared the cache several times and was able to have the rounded corners of the caption aligned with the padding of the image. But it promptly disappears after a while.

    is Elementor the problem? I don’t use it a lot, do I take it off? What happens to the text I wrote?

    During the test I tried the plugin you mentioned to me; Simple Custom CSS and JS.

    But it did not work.

    Plugin Support Arreane

    (@yanex)

    @ildomandatore I’m afraid helping you on how to add custom CSS code is out of our scope. The only reason I provided you the custom code is because it was very minimal. If you’re having trouble on how to integrate it in your theme, I’m afraid you’d have to contact a developer to help you with that.

Viewing 15 replies - 1 through 15 (of 21 total)
  • You must be logged in to reply to this topic.