Support » Plugin: WP Mega Menu » Left Align for SubMenu And Hover Color not changing

  • Resolved Divyansh Pratap Singh

    (@divyanshbhati)


    I am using WP Mega Menu in Chrome. And I want to Change the alignment of SubMenu, which is not changing with the Menu setting. And I also want to change the Hover color, which I am not able to change with Theme setting. Background color updated,but I dont Know why hover color is not updating.

Viewing 8 replies - 1 through 8 (of 8 total)
  • Plugin Contributor Md. Jakir Hosen

    (@joomcoder)

    Hello,

    Thanks for using our megamenu.
    You can align first level menu(main menu) from menu bar but currently no option available for submenu alignment.

    But you can use this CSS for submenu alignment. Go to Dashboard>Appearence>Customize>Additional CSS and input this CSS

    
    #wp-megamenu-primary>.wpmm-nav-wrap ul.wp-megamenu>li ul.wp-megamenu-sub-menu li a{
    text-align: right;
    }
    

    Give the hover color like this and must click on save changes button.
    http://prntscr.com/kw7h60

    Make sure you have used that theme which theme you edit & give border, shadow.
    http://prntscr.com/kw72jz

    Finally, save the menu & clear your browser cache.

    Regards
    Orko

    When I Hover on the Menu, it show no change in Sub-Menu alignment,but when I remove my mouse pointer from First-level Menu item,then just for half second it shows left alignment and then vanishes. But when again I Hover on it, same thing happens.

    Hover-color Problem resolved. Thanks

    And I Want to add a button too in Menu. When I searched it, I found this,but this is also has the same hover-color as the rest of the menu:-

    Go To Dashboard>Appearence>Menus edit the menu and give a class name there
    http://prntscr.com/koyb30

    See the screenshot for how to take the class.
    Then Go To Dashboard>Appearence>Customize>Additional CSS and input this CSS

    li.menu-btn a{
    background: #333;
    color: #fff;
    padding: 10px 20px;
    }
    Example: http://prntscr.com/koydjp

    And One more thing,when using “Plugin: Elementor” and putting menu code in Test-box.
    Menu bar(hover-color) and SubMenu (hover-color) doesn’t work at all.
    Bro, I like your plugin and I want to see it working Perfectly.

    And if you can come online more than once/day,then that would be great!

    Plugin Contributor Md. Jakir Hosen

    (@joomcoder)

    Hello,

    Sorry for my delay response.
    I apologize for this delay.

    We are working on Elementor issue, hope it will be fixed in our next update.

    And some time theme default menu CSS conflict with our mega menu, So I need to check your site.
    For more help, you can come to our support forum 🙂

    Regards
    Orko

    just saw your update. It solved the 2 minor issues like sticky menu background-color and Menu Bar Hover-color,but SubMenu hover-color and its Left-alignment is still not resolved. Please resolve that too.

    Hello,
    Check your email inbox.

    Waiting for your reply.

    Regards.

Viewing 8 replies - 1 through 8 (of 8 total)
  • The topic ‘Left Align for SubMenu And Hover Color not changing’ is closed to new replies.