Support » Plugin: leenk.me » leenk.me plugin overloading server

  • Resolved Sebastian

    (@wordpresscomsqlitynet)


    the leenk.me plugin is doing an ajax request every second when a post editor window is open. On a shared host that quickly overloads the server if more than one post is edited at the same time. Is there a way to stop or at least throttle this traffic. I can’t see why staying in contact with the server this frequently would be necessary for the function of this plugin.

    http://wordpress.org/extend/plugins/leenkme/

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author leenkme

    (@leenkme)

    Hi Sebastian… this is what generates the “live preview” for each social network. It shouldn’t be doing it every second though, should be every 3 seconds.

    Anyway, you can disable it be dequeue those scripts. You would add some code like this to your theme’s functions.php file:

    wp_dequeue_script( ‘leenkme_post_js’ );
    wp_dequeue_script( ‘leenkme_twitter_post_js’ );
    wp_dequeue_script( ‘leenkme_facebook_post_js’ );
    wp_dequeue_script( ‘leenkme_linkedin_post_js’ );
    wp_dequeue_script( ‘leenkme_friendfeed_post_js’ );

    You won’t get the live preview anymore, but everything else should work.

    Let me know if you run into any trouble.

    Sebastian

    (@wordpresscomsqlitynet)

    When I do that, will I still be able to manually change the content of each update?

    Plugin Author leenkme

    (@leenkme)

    You should be able to, yes. Let me know if it doesn’t work though.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘leenk.me plugin overloading server’ is closed to new replies.