Leaving Comments -- Taken to Sign In Page that Never Works -- Why? (2 posts)

  1. Qaiset
    Posted 2 years ago #

    I'm trying to leave a comment on the blog at http://www.roundtable.kemeticrecon.com/intro/ . The site's owners have both assured me that it ought to be accepting comments, and that it is set up correctly in order to do so. But, I still can't leave comments on their blog! I've tried and exhausted all their suggestions, my ideas, and possible solutions found in your support pages. This has been going on a week and I'm so frustrated; I've never had this sort of problem with WordPress before!

    What exactly happens is that I go to the website above: http://www.roundtable.kemeticrecon.com/intro/ , and then scroll down to the comment section. It says that in order to leave a comment, I must log in first. That shouldn't be a problem, as I have a WordPress.com account. That won't work. I tried signing up and logging in with an "IntenseDebate" (I think it is called that) account; that fails. Finally, I even resorted to trying my Twitter username/pw AND the login/pw I used to log in to these forums -- fails again. One thing I notice is that when it takes me to "log in," the page is WordPress.org -- not WordPress.com. But, the site owners say that shouldn't matter.

    Do you have ANY ideas as to what I'm doing wrong? I just want to leave a simple comment on their site -- help, please? Thank you!

  2. WPyogi
    Forum Moderator
    Posted 2 years ago #

    I'm really not familiar with Intense Debate, but looking at the plugin's forum, it looks like it may no longer be supported?


    You could try the contact form here:


    Or the site owners may want to consider using JetPack comments instead - looks like that may be what's replaced ID.


Topic Closed

This topic has been closed to new replies.

About this Topic