Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author blackandwhitedigital

    (@blackandwhitedigital)

    Hi

    Is this a consistent problem with all leave appllications or does it just happen in some circumstances? If it is occasional, can you see a pattern? We’d need to be able to narrow down the likely causes.

    Could you check for a plugin clash by turning off all your other plugins, then check to see if the error recurs. If not, then that will suggest a plugin clash. Then turn each one on again and check for the error until you identify the cause.

    It’s very hard to locate a cause for a random error but if you can find a pattern or regular occasion when this occurs we may be able to fix it.

    PLease let me know how you get on.

    kiattisakd

    (@kiattisakd)

    Hi,

    Thank you for your reply and guide, after I have tried your suggestion I have found one plugin that causes the problem, the name is “The GDPR Framework”.

    Thank you so much.

    Plugin Author blackandwhitedigital

    (@blackandwhitedigital)

    Thank you for updating me.

    I’ll pass this on to our dev team.

    I am having the same exact issue only deactivating all the plugins did not resolve my issue. Whenever I begin the Take a Leave process, once the date range is filled out, the Error, Object Object goes up. I also noticed one employee requested leave successfully two days ago, but the year in the date is 0000. This error is thrown for every instance of any new leave requests, no matter front or back end?

    Plugin Author blackandwhitedigital

    (@blackandwhitedigital)

    Sorry to hear you are having issues.

    Please check that leave is set up correctly.
    – have you created a specific location for the employees (do not use ‘All Locations’ or default)
    – have you linked the employees to that location
    – have you created a Leave Policy linked to that location?

    Please review http://www.wphrmanager.com/docs/wp-hr-manager/3-0-leave-management-module/

    Thanks for your quick reply…I have done all of your suggestions, yes. The Leave feature was working flawlessly for over 6 months! I did notice in the Audit logs that this most recent request was for a day in August, but on the Leave Requests page, it reads as: 11/30/-0001 00:00:00.

    I deleted this entry, then tried the request again. I was able to request leave normally, but again the date reads exactly as above. I am able to request additional leave for other employees, but again the date reads as such in the list..link below.

    Additionally I do not receive any confirmation emails for these?

    http://smartmarkglobal.com/smarthr/wp-content/uploads/2019/07/screenshot-smarthr.smartmarkglobal.com-2019.07.11-12-32-40.png

    Plugin Author blackandwhitedigital

    (@blackandwhitedigital)

    Hi Smartmaketglobal

    Can you file a support ticket for this at

    http://www.wphrmanager.com/submit-a-support-request/

    and let us have a screenshot of date formate setting screen. So we can check with this format and find the issue?

    Thanks,

    Paul

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Leave Request Error’ is closed to new replies.