Support » Plugin: Blog-in-Blog » Leave a Response not working

  • Resolved Johnny Blaze


    So I have used this plugin on a few sites now and WAS really happy with the results. On the sites I put it on previously, I had tested them extensively so I know they were working correctly at one point.

    The current site I am working on I installed the blog in blog plugin, but when I go to test I notice that when I click on “Leave a response” that is just takes you to the article post. So I went and checked the other sites I had previously used them on and knew that the “Leave a Response” was working.

    The weird part is now the “Leave a Response” is doing the same thing on all the sites. And no, the client nor myself have updated any plugins or WordPress version.

    I know at one point when I went to leave a “test” response I had to enter my name and email address, it even would recognize and show my gravatar.

    Has anyone else ran into this problem or have any suggestions on why this would happen or how to fix? I would be incredibly grateful as this sites deadline is rapidly approaching.

    Thank you!

Viewing 6 replies - 1 through 6 (of 6 total)
  • I have the same issue. You can see it here:

    It looks like the link for “leave a response” goes to #respond — which doesn’t exist on that page.

    Well I did find in the blog-in-blog.php file where the leave a response are being handled. Here is the code:

    * Process comment data and build a string
    function bib_process_comments($cStatus, $cCount, $permalink) {

    $out = ”;
    if (( $cStatus == ‘open’ && $cCount > 0 ) || ( $cStatus == ‘closed’ && $cCount > 0 )) {

    $out = ‘
    . sprintf(_n(‘%d Comment’, ‘%d Comments’, $cCount, ‘blog-in-blog’) . ‘ »’, $cCount) . ‘
    $out = ‘
    . sprintf(__ngettext(‘%d Comment’, ‘%d Comments’, $cCount, ‘blog-in-blog’) . ‘ »’, $cCount) . ‘
    } elseif ($cStatus == ‘open’) {

    $out = ‘
    . __(‘Leave a response ‘, ‘blog-in-blog’) . ‘»
    } elseif ($cStatus == ‘closed’) {

    $out .= __(‘Comments are closed’, ‘blog-in-blog’);

    return $out;

    The bad thing is I am fairly new to programming so I can’t tell what is going wrong. Im wondering if Im missing one of wordpress’s core files. I did not build the theme and it seems to be missing many of the core php files that are included in the 2011 or 2012 themes. I tried adding a few of the files like comments.php and page.php but neither made a difference.

    The thing that boggles my mind the most is I am 100% sure that it was working correctly at one point (on another site), I left test comments and had to approve them though the wp-admin panel, then went and erased them before pushing site to production server. Plus users have left comments since going live. I just don’t understand how It stopped working.

    I know updating a plugin or wordpress version can really wreck things sometimes but I nor client have done either.

    Sorry, didn’t paste code correctly, here is the correct code. It is lines 557-583 on blog-in-blog.php

     * Process comment data and build a string
    function bib_process_comments($cStatus, $cCount, $permalink) {
        $out = '';
        if (( $cStatus == 'open' && $cCount > 0 ) || ( $cStatus == 'closed' && $cCount > 0 )) {
                $out = '<a href="' . $permalink . '#comments" title="' . __('Comments', 'blog-in-blog') . '" >'
                    . sprintf(_n('%d Comment', '%d Comments', $cCount, 'blog-in-blog') . ' &raquo;', $cCount) . '</a>';
                $out = '<a href="' . $permalink . '#comments" title="' . __('Comments', 'blog-in-blog') . '" >'
                    . sprintf(__ngettext('%d Comment', '%d Comments', $cCount, 'blog-in-blog') . ' &raquo;', $cCount) . '</a>';
        } elseif ($cStatus == 'open') {
            $out = '<a href="' . $permalink . '#respond" title="' . __('Respond', 'blog-in-blog') . '" >'
                    . __('Leave a response ', 'blog-in-blog') . '&raquo;</a>';
        } elseif ($cStatus == 'closed') {
            $out .= __('Comments are closed', 'blog-in-blog');
        return $out;

    Hooray! I figured out the problem.

    I was missing a couple WordPress core files. When I added the single.php file everything started working again. I had to comment out a few lines, which you will see below. But if you cannot locate this single.php file just copy the code I pasted and try adding single.php to your wp-content/(active theme) folder.

     * @package WordPress
     * @subpackage Default_Theme
    	<div id="content" class="widecolumn" role="main">
    	<?php if (have_posts()) : while (have_posts()) : the_post(); ?>
    		<div class="navigation">
    			<div class="alignleft"><?php previous_post_link( '%link', '&laquo; %title' ) ?></div>
    			<div class="alignright"><?php next_post_link( '%link', '%title &raquo;' ) ?></div>
    		<div <?php post_class(); ?> id="post-<?php the_ID(); ?>">
    			<h2><?php the_title(); ?></h2>
    			<div class="entry">
    				<?php the_content('<p class="serif">' . __('Read the rest of this entry &raquo;', 'kubrick') . '</p>'); ?>
    				<?php wp_link_pages(array('before' => '<p><strong>' . __('Pages:', 'kubrick') . '</strong> ', 'after' => '</p>', 'next_or_number' => 'number')); ?>
    				<?php the_tags( '<p>' . __('Tags:', 'kubrick') . ' ', ', ', '</p>'); ?>
    				<p class="postmetadata alt">
    						<?php /* This is commented, because it requires a little adjusting sometimes.
    							You'll need to download this plugin, and follow the instructions:
    							/* $entry_datetime = abs(strtotime($post->post_date) - (60*120)); $time_since = sprintf(__('%s ago', 'kubrick'), time_since($entry_datetime)); */ ?>
    						<?php /* printf(__('This entry was posted on %1$s at %2$s and is filed under %3$s.', 'kubrick'), get_the_time(__('l, F jS, Y', 'kubrick')), get_the_time(), get_the_category_list(', ')); */ ?>
    						<?php /* printf(__("You can follow any responses to this entry through the <a href='%s'>RSS 2.0</a> feed.", "kubrick"), get_post_comments_feed_link()); */?> 
    						<?php if ( comments_open() && pings_open() ) {
    							// Both Comments and Pings are open ?>
    							<?php /* printf(__('You can <a href="#respond">leave a response</a>, or <a href="%s" rel="trackback">trackback</a> from your own site.', 'kubrick'), get_trackback_url()); */?>
    						<?php } elseif ( !comments_open() && pings_open() ) {
    							// Only Pings are Open ?>
    							<?php printf(__('Responses are currently closed, but you can <a href="%s" rel="trackback">trackback</a> from your own site.', 'kubrick'), get_trackback_url()); ?>
    						<?php } elseif ( comments_open() && !pings_open() ) {
    							// Comments are open, Pings are not ?>
    							<?php _e('You can skip to the end and leave a response. Pinging is currently not allowed.', 'kubrick'); ?>
    						<?php } elseif ( !comments_open() && !pings_open() ) {
    							// Neither Comments, nor Pings are open ?>
    							<?php _e('Both comments and pings are currently closed.', 'kubrick'); ?>
    						<?php }/* edit_post_link(__('Edit this entry', 'kubrick'),'','.');*/ ?>
    	<?php comments_template(); ?>
    	<?php endwhile; else: ?>
    		<p><?php _e('Sorry, no posts matched your criteria.', 'kubrick'); ?></p>
    <?php endif; ?>
    <?php get_footer(); ?>

    I have a single.php file in my theme directory. Any other ideas?


    I’m sure you have checked this out but just to make sure, have you opened your single.php file up. The first single.php file I tried using didn’t work but I found the one I pasted above and it worked for me. The first one had about half the amount of code.

    I would recommend and is what I had to do is deactivating your theme and activate the 2011 theme or some other default theme and see if it works. If it is just not working with your current theme then the problem lies there. You may also have to deactivate some plugins to see if your getting some conflicts there as well. I know from my limited WordPress experience that plugins can sometimes can wreck each other.

    I would also check your theme and compare it to a default one. Look to see what core php files the default theme has compared to yours. I don’t know if you built the theme yourself, but our developers who specifically build WordPress and Coldfusion themes sometimes omit the core files that they dont need. I had to upload file by file until I noticed things were doing something. I know very amateur but since Im working on a dev server Im not too worried about wrecking anything.

    Sorry man, I wish I had a better answer for you. Please keep me posted how you do, if you find a solution to your problem it would be nice to know for future reference.

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Leave a Response not working’ is closed to new replies.