WordPress.org

Support

Support » Plugins and Hacks » BadgeOS » [Resolved] Leave a Reply not appearing on badges/task I create

[Resolved] Leave a Reply not appearing on badges/task I create

  • Via Firebug I can see that all BadgeOS tasks and badges use the Post template create the badges. All the example badges and tasks that came with the plugin show the Leave a Reply comment field however, when I create my own taks or badges the Leave a Reply field does not show up. Also, I made some changes to one of the example badges (change how badge was earned: from “Completing Steps” to “Submission”) which then caused the Leave a Reply field disappeared.

    I’ve change the theme and the problem remains. I don’t believe there are any conflicts with other plugins since some of the badges have the comment field and some don’t and because that one example badge I changed once had the field and then didn’t.

    Any help with this issue would be greatly appreciate. Below are links to two of the badges currently on my site. One example badge and one that I made.

    Example Badge
    http://www.biologydesign.com/WordPress/quest-badge/badge-issuer/

    Created Badge
    http://www.biologydesign.com/WordPress/quest-badge/coastal-forest-replanting-badge/

    http://wordpress.org/extend/plugins/badgeos/

Viewing 7 replies - 1 through 7 (of 7 total)
  • Have you made sure that comments are enabled when editing the badges? If they are and you’re still not seeing them, I’ll try and help best I can further.

    Thanks Michael for the reply. I don’t see any option for enabling or turning off commenting (other than adding the “submission” form which works fine) in the badge settings. All the settings are the same in the ones I create and the examples that came with the plugin, yet mine don’t show the comments field while the examples do.

    Plugin Author Brad Williams

    @williamsba1

    Badges don’t have the Discussion metabox enabled by default, so you can’t toggle comments on or off.

    My guess is your theme is not verifying whether comments are enabled or not before displaying the “Leave a Comment” link, because that shouldn’t be shown on individual badge pages.

    Thank you for the reply Brad. If my theme isn’t verifying whether comments are enabled or not then why does the Comments field appear on some badges (plugin examples) but not on others (one I’ve created)? That’s the most confusing part for me.

    And if it turns out that I do need to include a Discussion metabox to the badges do I do that in the metaboxes.php file within the BadgeOS plugin?

    Thanks again.

    hey Seahawksean, curious if you’re still having issues/questions with this or if you found a solution of some sort.

    hey Seahawksean, curious if you’re still having issues/questions with this or if you found a solution of some sort.

    hey Seahawksean, curious if you’re still having issues/questions with this or if you found a solution of some sort.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘[Resolved] Leave a Reply not appearing on badges/task I create’ is closed to new replies.
Skip to toolbar