WordPress.org

Support

Support » How-To and Troubleshooting » [Resolved] "Leave a comment" is appearing on the wrong page!

[Resolved] "Leave a comment" is appearing on the wrong page!

  • nataliemin

    @nataliemin

    I am using (and loving) the Gridiculous template, but I can’t get the comments section to appear where I want it to, ie, on the blog page.

    The “Leave a reply” box appears on the home page, even though I have unchecked the Discussion and Comments box under “Screen Options”. I don’t want a comments box on the home page.

    I have also unchecked the “Allow people to post comments on new articles” box on the Settings – Discussion screen, but the “Leave a reply” box will not go away.

    At the same time, I would like to enable comments on posts, but there is no “Leave a reply” box on the blog page, only a line that says “Comments are closed”, even on a post I have just published, and even though I have checked the Comments and Discussion boxes on the posts. Can anyone help?

Viewing 2 replies - 1 through 2 (of 2 total)
  • “Screen Options” simply sets which options are shown on your edit page. When you click the “Discussions” box it makes visible the Discussion options at the bottom of the page. Uncheck the “Allow Comments” box and update your page.

    You will need to do this for every page that you do not want comments on that was created before you turned comments off in Settings>Discussion.

    nataliemin

    @nataliemin

    Fantastic – that’s it sorted now. Thanks!

Viewing 2 replies - 1 through 2 (of 2 total)
  • The topic ‘[Resolved] "Leave a comment" is appearing on the wrong page!’ is closed to new replies.
Skip to toolbar