Support » Plugin: SportsPress - Sports Club & League Manager » League Table Blank Page if more than 13 teams.

  • So my billiards league website, which has been working fine for years, suddenly hangs and doesn’t get past a blank page when I try to load a page that has a league table with 14 or more teams. It took some testing to narrow down the problem, but 14 teams seems to be the issue. We have a Wednesday night league and a Tuesday night league, and since Wednesday only has 11 teams it loads fine, but if I try to load the tuesday standings page, or any team page that shows the standings, it hangs and just stops on a blank white page.

    To test, I created a new table and added one team at a time. My first thought was that one of the teams might be corrupt somehow so I was trying to see which team it was. I got to 13 teams, and then when I added the 14th team to the table the problem repeated itself. I tried a different 14th team and the problem was still there, so it wasn’t a specific team, but rather, adding the 14th team to the table. Not only does viewing the page hang, but editing the page hangs as well, so if I’m in the dashboard and editing the league table, once I add the 14th team and push the update button, that page hangs as well.

    I’ve upped the memory in my config.php to 512M as well as the max memory limit, but that hasn’t helped.

    Before this issue happened, I just did my score updates like normal. Nothing weird, no odd stats or anything out of the ordinary. All plugins and wordpress are up to day. It isn’t a theme issue because I tried it with a newly updated twentytwenty theme. The pages load fine if I remove the league table. I’m at a loss here. Any ideas would be appreciated.

Viewing 2 replies - 1 through 2 (of 2 total)
  • By the way, the site is http://westside8ball.com

    http://www.westside8ball.com/tuesday-schedule-and-standings/ is the tuesday standings page that hangs

    http://www.westside8ball.com/wednesday-schedule-and-standings/ is the wednesday standings page that works just fine.

    Well, I figured it out. Turned on debugging and saw a lot of errors referencing lines in class-sp-league-table.php relating to minutes. The errors were that there was a non numeric value at that line. Here’s an example:

    $totals[ $team_id ][‘eventminutes’] += $minutes;

    Since billiards doesn’t use time, the minutes field in settings has been blank. Filling in 0 fixed the issue. I believe that 14 teams in the table was the break point at which there were too many errors for the page to load.

    Perhaps in a future update, if minutes is left blank in the settings:

    Sportspress->Settings->Events->Full Time

    replace with a 0 to avoid the issue…or make 0 the default until someone fills it in, or whatever.

    Hopefully this will help anyone else who has the same issue.

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.