WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Leaflet Maps Marker plugin support for Google Maps as basemaps at EdWeWo.com

[Resolved] Leaflet Maps Marker plugin support for Google Maps as basemaps at EdWeWo.com

  • Hi Robert

    Thank you for creating one of the best WordPress plugins. I have just updated the Leaflet Maps Marker plugin to the latest version. Unfortunately the update has triggered the following issue on my website EdWeWo.com:

    ” The Google Maps API server rejected your request. The “sensor” parameter specified in the request must be set to either “true” or “false”. “

    If I disable the plugin the issue disappears. I suspect that the issue is related to the plugin’s new feature:

    ” support for Google Maps as basemaps “

    Your assistance in resolving this issue will be much appreciated.

    Thank you
    Dragan Lakic
    [ Signature moderated. ]

    http://wordpress.org/extend/plugins/leaflet-maps-marker/

Viewing 15 replies - 1 through 15 (of 24 total)
  • Plugin Author RobertHarm
    Participant

    @harmr

    Hi Dragan,

    Thanks for your great feedback – this really motivates me to keep on improving my plugin 🙂

    Concerning your sensor issue: I checked the code – the sensor parameter gets added to the google maps api url – if you look into the source code of mapsmarker.com you will see

    http://maps.google.com/maps/api/js?v=3.2&sensor=false&language=en&ver=3.4.1

    Strange thing is, that on your site only

    http://maps.google.com/maps/api/js

    Gets added to the source code.
    My guess is that another plugin could be interfering with how js gets added.
    So please try the following: disable all other plugins and check if the warning still shows up & the google maps api url is like on mapsmarker.com.
    If yes, please re-enable all plugins one by one to find the one which is causing the error & tell me this one please.

    If this doesnt help, please check with your webhoster if he uses any special configuration which could cause this behaviour,
    Regards

    Robert

    PS: it would be great if you could vote for my plugin on wordpress.org 😉

    Hi Robert

    Thank you very much for your prompt reply. Your response has pointed to the right direction to resolve the issue.

    As per Google’s Web Page Performance Audit, resources with a “?” in the URL are not cached by most proxy caching servers. To leverage proxy caching I have added the following lines to the theme’s functions.php file:


    // Remove the query string and encode the parameters into the URL
    function _remove_script_version( $src ){
    $parts = explode( ‘?’, $src );
    return $parts[0];
    }
    add_filter( ‘script_loader_src’, ‘_remove_script_version’, 15, 1 );
    add_filter( ‘style_loader_src’, ‘_remove_script_version’, 15, 1 );

    Removing the lines above resolves the issue.

    I would still like to leverage proxy caching for my website EdWeWo.com and your solution will be much appreciated. The solution could be a some kind of on/off switch for the plugin’s new feature:

    ” support for Google Maps as basemaps ” …

    Thank you
    Dragan Lakic
    [ Signature moderated. ]

    P.S. I have just placed my vote (# 3) for your plugin on wordpress.org – 3 people say it works!

    Plugin Author RobertHarm
    Participant

    @harmr

    Hi Dragan,
    great you found a solution – will also try to find a way to make it work even for sites with proxy servers. Give me some time. If I dont find a solution, I will consider adding a switch to turn off the Google Maps integration.
    Regards,
    Robert

    Hi Robert

    Thank you very much for your prompt reply and for your great support. Even though it was Sunday here in Bulimba, Queensland, Australia, as well as in your part of the World, we have found the solution in only a couple of hours.

    Please let me know as soon as you find a solution to leverage the proxy caching for my website EdWeWo.com.

    Thank you
    Dragan Lakic

    Plugin Author RobertHarm
    Participant

    @harmr

    Hi Dragan,
    you are welcome – feedback like your helps improving my plugin as I dont have the time and ressources to test every possible configuration.

    Unfortunately I still dont have a clue how to fix this issue – I did some research, posted a question on wpquestion.org – but with no success yet.

    One idea: could you please try installing other Google Maps plugins? As they will also have to embedd the script, I wonder if one of the plugin authors used another method to implement the script. If you find a plugin which uses the script and doesnt display the error message, please tell me and I will take a look into the sourcecode
    regards,
    Robert

    Hi Robert

    Thank you once again for your great support.

    I have tested all the WordPress Maps plugins and the 2 which are the best for the EdWeWo project are your plugin and MapPress Easy Google Maps plugin.

    Please have a look at the EdWeWo’s FREE Semantic Maps below, which are utilising these 2 plugins:

    FREE Semantic Maps of Suburbs – Morningside, Queensland, Australia
    http://edwewo.com/suburbs/morningside-queensland-australia/

    FREE Semantic Maps of Best Brands in Queensland, Australia
    http://edwewo.com/best-brands/queensland-australia/

    FREE Semantic Maps of Brands Owners in Queensland, Australia
    http://edwewo.com/brands-owners/queensland-australia/

    The clue could be in the MapPress Easy Google Maps plugin, because it does not display the error message …

    Thank you
    Dragan Lakic

    Plugin Author RobertHarm
    Participant

    @harmr

    Hi Dragan,
    thanks for the info – I analyzed the plugin and found that it uses another method for loading the script needed from Google. Will include this method in v2.6 whoch will be released later this week,
    best regards,
    Robert

    Hi Robert

    That is great news! I will be more than happy to test the new release v2.6.

    Please let me know as soon as it is ready to test it on my website EdWeWo.com.

    Thank you
    Dragan Lakic

    Plugin Author RobertHarm
    Participant

    @harmr

    Please download & test with the latest code on github – should solve your issue.

    Plugin Author RobertHarm
    Participant

    @harmr

    The URL for github zip download is https://github.com/robertharm/Leaflet-Maps-Marker/zipball/dev (latest version) by the way

    Hi Robert

    Thank you for your quick reply and for your great coding. I have downloaded the latest code and will test it on EdWeWo.com tomorrow.

    Thank you
    Dragan Lakic

    Plugin Author RobertHarm
    Participant

    @harmr

    Hi Dragan,
    I found a nasty bug – please re-download the package from github if you want to test before the official v2.6 release (which will be released hopefully today or tomorrow).
    regards,
    Robert

    Hi Robert

    Thank you for your information. I was so confident and that nasty bug did not stop me to test your latest code on my live website EdWeWo.com.

    So before I installed the latest code v2.6, I have deactivated the current code v2.5. The v2.6 was installed in a new folder and the following are my test results:

    1.
    Fatal error:
    Cannot redeclare class lmm_recent_marker_widget in wp-content/plugins/robertharm-Leaflet-Maps-Marker-d40356d/leaflet-maps-marker.php on line 1468

    which is this line:
    }//info: END class lmm_recent_marker_widget extends WP_Widget

    2.
    Recent marker widget error:
    The WordPress plugin Leaflet Maps Marker is inactive on this site and therefore this API link is not working.
    Please contact the site owner who can activate this plugin again.

    3.
    Default blue pin marker icon and the EdWeWo favicon marker icon (E*) were showing up on Marker Maps, but not on Layer Maps, even though a list of markers has been displayed under the Layer Maps.

    After my testing I have deactivated the v2.6 and uninstalled it. Unfortunately, all my markers and all my layers have disappeared with the v2.6 and now the EdWeWo.com is running without the Leaflet Maps Marker plugin.

    Please follow the links below to see how your plugin is really the missing piece on the EdWeWo.com pages:

    FREE Semantic Maps of Suburbs – Bulimba, Queensland, Australia
    http://edwewo.com/suburbs/bulimba-queensland-australia/

    FREE Semantic Maps of Best Brands in Australia
    http://edwewo.com/best-brands/

    FREE Semantic Maps of Brands Owners in Australia
    http://edwewo.com/brands-owners/

    It must be because of the Mercury in Retrograde … so I will wait for the official v2.6 release and then install all my markers and all my layers back on EdWeWo.com and also test the “sensor” issue.

    Thank you
    Dragan Lakic

    Plugin Author RobertHarm
    Participant

    @harmr

    installing a plugin twice with only a different folder name will definitely result in those errors. As I will release v2.6 later this evening, I ask you to test with the official version. If the problem still exists, making v2.6.1 shouldnt be a problem 😉

    Hi Robert

    Thank you for your reply. I just did not want to lose my markers and my layers on my live website EdWeWo.com.

    In addition, I had the same Layer Maps issue with the v2.4 and I had to switch back to default blue pin marker icon from the EdWeWo favicon marker icon E*.

    I am waiting for the official v2.6 release to install all my markers and all my layers back on EdWeWo.com and also to test the “sensor” issue.

    Thank you
    Dragan Lakic

Viewing 15 replies - 1 through 15 (of 24 total)
  • The topic ‘[Resolved] Leaflet Maps Marker plugin support for Google Maps as basemaps at EdWeWo.com’ is closed to new replies.