Support » Plugin: Zoho CRM Lead Magnet » Lead creation not working an hour after the plugin has been setup.

  • Resolved Marc Jauvin

    (@mjauvin)


    Am I the only one with this problem?

    I activated and linked the plugin with my Zoho CRM account, setup a form with Contact Form 7 and it worked beautifully.

    I waited an hour and a half, and now, the form that successfully created Lead in Zoho CRM does not create the lead anymore (with no change on my end).

    So I’m guessinbg the access_token does not get refreshed once it expires (or something like that).

    Can you look into this, it is pretty useless if it stops working after an hour or so.

    Thanks.

Viewing 4 replies - 1 through 4 (of 4 total)
  • After some investigation, it looks like the refresh_token does not get saved into the wp_options table’s “zcf_crmformswpbuilder_settings”.

    So I am guessing this is why the access_token does not get refreshed as it should…

    When the API call to generate the access_token+refresh_token returns, I logged the output and here is what I get in my logs:

    [20-Oct-2018 15:14:50 UTC] {“access_token”:”1000.383e1b28720da39e43872b9e4cf4a2cc.7a6ec654c5557d587e11dd1c08736c71″,”expires_in_sec”:3600,”api_domain”:”https://www.zohoapis.com”,”token_type”:”Bearer”,”expires_in”:3600000}
    [20-Oct-2018 15:14:50 UTC] PHP Notice: Undefined index: refresh_token in /home/chariot/public_html/wp-content/plugins/zoho-crm-forms/includes/crmoauthentication.php on line 37

    The REFRESH_CODE is not returned as it should… any idea how that might happen?

    I decided to start over, added a new Client ID in zoho developer console and this solved the issue.

    Somehow, the previous Client ID that was created did not behave properly.

    Plugin Author Zoho CRM

    (@zohocrm)

    Hi @mjauvin

    We will check and update

    Thanking you

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Lead creation not working an hour after the plugin has been setup.’ is closed to new replies.