Support » Plugin: Uncanny Toolkit for LearnDash » LD update and Topics Autocomplete Lessons module stopped working

  • Hello! I’m testing the latest LearnDash update (going from 3.2.2 to 3.2.3.3) and as soon as I updated, the last topic (a quiz) in the lesson no longer autocompletes the lesson and advances to the next lesson. Instead, when the quiz completes the user is taken back to the beginning of the current lesson. I haven’t changed anything else except the LD update. I ran this test on 2 different staging sites just to make sure. I’ve submitted an LD ticket, but also wanted to check here. Thank you!

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Uncanny Owl

    (@uncannyowl)

    Hi @lorilself, this sounds like it might be related to Toolkit Pro instead; if it is, we have better tracking on our website (in case we need additional info).

    Can you confirm exactly how the last topic you mention is set up? Is it a quiz associated with a topic (and if so, is that via embed or is it associated in the quiz settings or builder) or is this a standalone quiz? If it’s the latter, we wouldn’t expect it to work, but if it’s the former, it would be great to confirm what specific autocomplete modules you’re using in Toolkit Pro so that we can try to replicate the results.

    Thanks

    Thread Starter lorilself

    (@lorilself)

    Hello! I’m using the free Uncanny Toolkit for LearnDash plugin, not the Pro version. I have the Topic Autocompletes Lessons module toggled on, and it has been working great until I tested the latest LD update.

    Here is how I have the Lesson set up:
    -Lesson1
    -Topic1
    -Topic2
    -Topic3
    -Quiz1 – added in the Builder within the last topic, not as a standalone quiz step.

    Before the LD update, when the quiz was completed the “Click Here to Continue” button would appear and clicking it would take the user to the next Lesson. After the update the button takes the user to the beginning of the current lesson.

    Any thoughts? Please let me know if you need any other details. Thank you for the help!

    Thread Starter lorilself

    (@lorilself)

    I want to add to my previous description of the issue:

    When the last topic of Lesson 1 (a quiz within the topic) is completed and I get the “click here to continue” button and that button now takes me back to Lesson 1 – Lesson 1 is now marked complete on the nav sidebar, but I have to click the “next lesson” button at the bottom of the page to get to Lesson 2 (instead of being taken automatically to Lesson 2 as was happening before the LearnDash update.)

    I hope this adds more clarification to what is happening. Please advise – thanks!

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘LD update and Topics Autocomplete Lessons module stopped working’ is closed to new replies.