• Resolved pierre313

    (@pierre313)


    Hello,

    I allow myself to contact you to see with you a problem with lazyload. The page where the lazyload bug: https://gites-luchon-peyragudes.com/

    The lazyload takes into account only the first photo (lake of Oô), the url of the others are modified and are illegible. I tried to exclude .background-slider but without success.
    Disabling u lazyload solves the problem.

    The installed version is 2.6.1

    Thanks for your help and for this plugin;)

    The page I need help with: [log in to see the link]

Viewing 5 replies - 1 through 5 (of 5 total)
  • Plugin Author Optimizing Matters

    (@optimizingmatters)

    Salut Pierre;
    I had a quick look and it seems as though lazyload is still active and -on my end at least- things seem to be working?

    Bien à toi,
    frank

    Thread Starter pierre313

    (@pierre313)

    For this part there is no problem, I am talking about this part, just below:

    When you pass the cursor over one of the images, the background changes, but it only works for the first (lac d’oo). In my opinion it comes from lazyload which does not apply to others.

    • This reply was modified 4 years, 4 months ago by pierre313.
    Plugin Author Optimizing Matters

    (@optimizingmatters)

    OK, I see what’s happening (the slider JS is changing classes so lazyloadin fails so when swapping background image the real image isn’t found), you’ll have to disable lazyloading of background images with this code snippet;

    add_filter( 'autoptimize_filter_imgopt_lazyload_backgroundimages', '__return_false');

    frank

    Thread Starter pierre313

    (@pierre313)

    It works, thank you very much for your speed.

    Good parties of New Year

    Pierre Cazeneuve

    Plugin Author Optimizing Matters

    (@optimizingmatters)

    Happy it works Pierre! Feel free to leave a review of the plugin and support here! 🙂

    Bon réveillon!
    frank

Viewing 5 replies - 1 through 5 (of 5 total)
  • The topic ‘Lazyload and slider’ is closed to new replies.