Support » Plugin: Smush - Optimize, Compress and Lazy Load Images » Lazy loading not working with Maintenance plugin

  • Resolved Tuh


    When I use the plugin Maintenance, the images are not showing up if I enable lazy loading in Smush.
    Any ideas about a fix? Thank you!!

Viewing 4 replies - 1 through 4 (of 4 total)
  • Plugin Support Pawel – WPMU DEV Support


    Hello @tuh

    I trust you are doing well!

    I’ve tested both plugins on my end and could replicate this issue. I’ve reported this to our developers.

    As a temporary workaround, pelase go to the Smush > LazyLoad and deactivate Lazy Load on a front-page as shown in this screenshot:

    Kind regards,

    Thread Starter Tuh


    Hey Nastia,

    Thanks for the update!

    All going well for me, thank you! I hope the same for you!!

    Let me know if I can help in any way.


    Hi @tuh,

    I have tested the Maintenance plugin. The plugin uses a custom theme template and removes all the assets from all other plugins, effectively removing Smush lazy loading scripts and styles. I would recommend asking their support if they can add an option to bring back wp_head and wp_enqueue_scripts actions into the template.

    Also, lazy loading is only effective for images that are below the fold (that means images that you don’t directly see on the browser screen and you have to scroll to). I can provide a temp fix, but it won’t really improve the performance of images that are in direct view.

    Best regards,

    Thread Starter Tuh


    Hey Anton,

    Thanks for your answer.
    I don’t really need to lazy load the images when the maintenance mode is on.
    I am fine with deactivating lazy load on the front-page when enabling it for now.

    Thank you very much!

Viewing 4 replies - 1 through 4 (of 4 total)
  • The topic ‘Lazy loading not working with Maintenance plugin’ is closed to new replies.