• Resolved edinmaloku

    (@edinmaloku)


    I’m lazy loading all my images and it seems to be working except on 2 images, those being background images. I also have another background image but it seems to be working on that one. Any idea what can be wrong?

    https://prnt.sc/10twuma

    Thanks!

Viewing 9 replies - 1 through 9 (of 9 total)
  • Plugin Support Dmytro – WPMU DEV Support

    (@wpmudevsupport16)

    Hi there @edinmaloku

    Looking at the source code of your site, we can see that the performance options in Jetpack are enabled, and they may indeed be conflicting.

    Try disabling the Jetpack performance options, clear all caches, then re-enable Smush lazy load feature.

    Please do le us know if this helps or if you still need assistance with this.

    Cheers!
    Patrick

    Thread Starter edinmaloku

    (@edinmaloku)

    Nope, didn’t work. Disabled Jetpack fully. The two pictures still give the same error.

    Plugin Support Pawel – WPMU DEV Support

    (@wpmudev-support9)

    Hi @edinmaloku,

    Are you able to disable the performance settings and jetpack and clear any caching you may have with your site or hosting setup? We are currently seeing the images being loaded over Jetpack’s CDN: https://i0.wp.com/efektipozitiv.com/wp-content/uploads/2021/02/logotestep.png?w=820&ssl=1

    Best,
    Jonathan S

    Thread Starter edinmaloku

    (@edinmaloku)

    I disabled the stuff you asked me to and tested it myself, after it didn’t work I just re-enabled it. I’ll re-disable it for you to check.

    Thread Starter edinmaloku

    (@edinmaloku)

    Done. Jetpack is disabled and images are not being served through their CDN anymore.

    Plugin Support Predrag – WPMU DEV Support

    (@wpmudev-support1)

    Hi @edinmaloku,

    It seems that there was some confusion here previously, the two reported images are loaded as background images in CSS (as you mentioned previously) and this is why the lazy loading doesn’t work, as it can’t be applied to background image.

    You mentioned that you have another image as background that is not reported, but from what I can see this is your header image that is loaded instantly (not on scroll) so this one doesn’t require lazy loading.

    Cheers,
    Predrag

    Thread Starter edinmaloku

    (@edinmaloku)

    That explains it, is there a way to lazy load these two background images or is that not possible?

    Plugin Support Dmytro – WPMU DEV Support

    (@wpmudevsupport16)

    Hi again @edinmaloku

    I must apologize as I totally missed the fact these are background images, even though you noted that twice in your original post… musta been a loooong day. 😀

    Unfortunately no, as Predrag noted, Smush cannot lazy load background images that are declared in your stylesheets.

    Cheers!
    Patrick

    Plugin Support Nithin – WPMU DEV Support

    (@wpmudevsupport11)

    Hi @edinmaloku,

    Since we haven’t heard from you in a while, I’ll mark this thread as resolved for now. Please feel free to re-open the thread if you need further assistance.

    Best Regards
    Nithin

Viewing 9 replies - 1 through 9 (of 9 total)
  • The topic ‘Lazy loading not working on 2 images’ is closed to new replies.