Support » Plugin: SG Optimizer » Lazy Load Not Working After Update

  • Resolved astromono

    (@astromono)


    Hello,

    I recently updated to 5.3.4 and suddenly none of my images or embeds will show unless I disable lazy load altogether in the plugin. This is happening even for external images that are loaded from a remote URL (like Giphy.com for example).

    The images appear fine in the WordPress editor, but they aren’t loaded at all in the published post.

    Thanks in advance for any assistance you can provide.

    Luis

    The page I need help with: [log in to see the link]

Viewing 2 replies - 1 through 2 (of 2 total)
  • Plugin Author Stanimir Stoyanov

    (@sstoqnov)

    SiteGround Representative

    Hey @astromono

    In the latest update, we’ve moved the lazyload script in the footer in order to make the script non-blocking.

    I’ve checked your site and the Lazyload functionality is not working.

    The problem is that you don’t call the wp_footer() function in your footer.php file. It exists, but there is conditional logic before the function call and that conditions are not met.

    The theme which you are using is a premium theme and the footer is different, which makes me think that you have changed the file.

    If you want to use the Lazyload, please change the logic in the footer.php file, so that the wp_footer() is called.

    Regards,
    Stanimir

    Hi, Stanimir

    Thank you so much for clearing this info. I have enabled the footer by testing it with dummy widgets and indeed the lazy load works fine now.

    Thanks again for the quick response and keep up the awesome work!

    Kind regards,

    Luis

Viewing 2 replies - 1 through 2 (of 2 total)
  • You must be logged in to reply to this topic.