Support » Plugin: Gutenberg Post Blocks » Lazy loading not supported and paginated results not having CDN prefix

  • Resolved hehachris

    (@hehachris)


    The plugin is great but there are two minor bugs:

    1. Native image lazy loading is not supported. (loading=”lazy” not added to thumbnails)

    2. Thumbnails loaded by pagination are not having CDN prefix.

    • This topic was modified 2 months, 2 weeks ago by hehachris.
Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author wpxpo

    (@wpxpo)

    Hi @hehachris,

    Thank you for choosing our post blocks plugin. I am sorry to say we don’t notice the native image lazy loading not working with our plugin. I already inform our development team about this issue. I hope they will add support to the native image lazy loading feature.

    I am not clear about your 2nd issue (CDN prefix). Could you please tell me the details? Better share the screenshot.

    Have a nice day.

    Let me rephrase – post thumbnails on the first page are all correctly served through CDN (CDN URL prefix is configured with another plugin); but all post thumbnails after page 1 are served directly from the site domain.

    Plugin Author wpxpo

    (@wpxpo)

    Hi @hehachris,

    I already told our development team about this issue. Within a few days, they will release an update. 2nd phase they will start work for your issue.

    Have a nice day.

    Hi @wpxpo, I have upgraded the plugin to 2.0. How do I enable image lazy loading?

    And it seems that the CDN issue is still not fixed?

    Plugin Author wpxpo

    (@wpxpo)

    Hi @hehachris,

    We have fixed the Image Lazy Loading issue. But I am sorry to say, our developer can’t understand the CDN issue properly. If you have any more questions let me know. I will try to solve your problem as soon as possible.

    Have a nice day

    Thanks, image lazy loading is working now!

    For the CDN bug, it’s not that complicated….in short, thumbnails of posts loaded by pagination are served directly via the site domain but not CDN…..

    For example –

    CDN domain: mycdn.com
    Site domain: mydomain.com

    Pagination Type: “Load More”
    Query -> Number of Post: 10

    For the first 10 posts, thumbnails are served via mycdn.com correctly. When I hit the “Load More” button, 10 older posts will be shown. But the thumbnails of these 10 older posts are served via mydomain.com.

    Plugin Author wpxpo

    (@wpxpo)

    Hi @hehachris,

    Thank you so much for your time and good guideline. I will forward your message to our development team. Hope they will try this issue.

    Have a nice day.

Viewing 7 replies - 1 through 7 (of 7 total)
  • You must be logged in to reply to this topic.