Support » Plugin: AMP for WP - Accelerated Mobile Pages » Lazy load images

  • Hi,
    I’m having problem with lazy load images on AMP pages. Since the script for lazy load is disabled images won’t load. I’m using Crazy Lazy plugin. I know it’s easy just deactivate it, but it’s improving loading times and PageSpeed score. Google still not using AMP in EU sadly so it’s not very important, but if you know how to fix it, would be awesome. Thanks.

    For example here is the problem: AMP page

Viewing 10 replies - 1 through 10 (of 10 total)
  • You should try using kraken or smush for image optimisation so they are optimize and minimal load time even without lazy loaf

    I have minified images before upload. But lazy load is much better than minified images. There is no need to make them even smaller the quality would be terrible. And load times are lot better for users with slow internet speed.

    Plugin Contributor ampforwp

    (@ampforwp)

    Hey @mattthev

    Thank you so much for using our plugin.

    I have this as an issue in Github and this will be fixed in future updates our plugin.

    Hi,

    Any update for this? It’s very important.

    An easy solution should be to just disable the lazy load js from accessing amp code.

    Thanks

    Plugin Contributor ampforwp

    (@ampforwp)

    Hi @manux_os,

    What issue are you facing?

    We have added the compatibility with lazy load plugins.

    If you have any issues, please let me know so that I can help you.

    Regards
    Marqas

    Hi and thanks for your reply,

    I am using my themes option for lazy load, but i have tried some plugins for lazy load and the result is the same.

    Here is my website: TechValue.gr, you can try the amp post articles, you will not see the images. I am using MagXP theme. I can send it if you want cause it’s a paid one.

    Regards

    Hi @ampforwp

    Did you check the error?

    Regards

    Plugin Contributor ampforwp

    (@ampforwp)

    Hi @manux_os,

    I checked and images are loading in AMP.

    Can you check again?

    Regards
    Marqas

    Hi @ampforwp,

    Thanks for looking but it’s been to much time and i disable the lazy load.

    Can you please have a look now? I just enabled lazy load.

    website: TechValue.gr

    Regards

    • This reply was modified 2 years, 5 months ago by Manux_oS.
    • This reply was modified 2 years, 5 months ago by Manux_oS.
    Plugin Contributor ampforwp

    (@ampforwp)

    Hi @manux_os,

    This is a one-off situation, and there is a limitation of help here, so can you contact us at https://ampforwp.com/support/#contact

    Regards
    Marqas

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Lazy load images’ is closed to new replies.