Support » Plugin: Flying Images by WP Speed Matters » Lazy Load Function is Not Working

  • Resolved ptm282192

    (@ptm282192)


    Hi there!

    My theme for some reasons doesn’t support your lazyload functionality (which is available in your plugin tab) but I noticed that Autoptimize plugin lazyload function is working perfectly with my theme.

    When I use Autoptimize lazyload and your plugin CDN functions – they don’t work together, autoptimize lazyload loading assets from server directly, not via statically CDN.

    Just wondering, may you please add a lazyload function the same as Autoptimize plugin does but in your plugin (to be available in your dropdown menu where Native or Javascript option to choose) to be able to use autoptimize lazyload functionality and serve images from the statically CDN?

    How can it be done?
    Thank you in advance!
    Regards

    • This topic was modified 5 months ago by ptm282192.
Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author Gijo Varghese

    (@gijo)

    @ptm282192 without knowing your site and access to it, I really can’t help.

    For now try Statically official plugin with Autoptimize.

    ptm282192

    (@ptm282192)

    Thank you!
    May you just include Autoptimize lazyload method into your plugin?

    Plugin Author Gijo Varghese

    (@gijo)

    @ptm282192 we’ve our own way 🙂

    ptm282192

    (@ptm282192)

    But if your lazyload do nothing, maybe add some option which is working and it will help a lot of others who facing the same issue – lazyload is not working.

    Plugin Author Gijo Varghese

    (@gijo)

    @ptm282192 how did you conclude that its lazy loading is not working?

    Then why 4k+ websites are using this plugin?

    ptm282192

    (@ptm282192)

    When testing with Page speed insights get constant error: Defer offscreen images.

    When using autoptimize lazyload it doesn’t display that error and it actually can be seen how autoptimize lazyload is working – when you scroll the page the images starting to appear slowly, but in your plugin all the images just appear simultaneously as it is when lazyload is turned off.

    • This reply was modified 5 months ago by ptm282192.
    Plugin Author Gijo Varghese

    (@gijo)

    @ptm282192 which option did you select lazy loading settings?

    ptm282192

    (@ptm282192)

    Native+JS
    500px

    Plugin Author Gijo Varghese

    (@gijo)

    @ptm282192

    1) Google PSI might flag anything above 300px else, not lazy load. So try setting it to below 300px.

    2) You’re using ‘Native + JS’. Native lazy loading loads more images that JS-based lazy loading. It’s set by the browser. If you want more control, use “JS only” lazy load.

    3) Many testing tools haven’t updated to detect native lazy loading.

    Flying Images is built for the best user experience, not to please any testing tools. Just because Google PSI said “Defer offscreen images”, that doesn’t mean images are not lazy-loaded.

    “just include Autoptimize lazyload method into your plugin”, WE’RE NOT AUTOPTIMIZE.

    ptm282192

    (@ptm282192)

    Thank you for the update!
    Will try to tweak the settings and update
    Thank you for the great plugins you’ve made by the way!

Viewing 10 replies - 1 through 10 (of 10 total)
  • You must be logged in to reply to this topic.