Support » Plugin: LiteSpeed Cache » Lazy Load and Report Number

  • Resolved Ahmad Al Maaz

    (@music47ell)



    Hi,

    I am in the process of replacing multiple plugins with LiteSpeed Cache WordPress Plugin.

    Now, I am trying to replace the BJ Lazy Load plugin. But I encountered few things that I need your help with.

    1. When I try to use the placeholder in wp-config.php I get Error 500.

    2. After testing my site on PageSpeed, under Optimization Suggestions, I get a suggestion to Optimize images although I have Lazy Load enabled and I am using the placeholder from within the plugin setting page. But when using BJ Lazy Load plugin, this suggestion doesn’t show up.

    This one is important because the score is way much better when I use the BJ Lazy Load plugin due to the fact that the only image that is being loaded, is my placeholder image which is optimized.

    But when testing the site with the LiteSpeed Lazy Load option enabled, somehow all the images are loaded during the test, making the score way worse.

    3. When enabling the Lazy Load option, there is a new request made to the file min/lazyload.js. Is there any way to get rid of this extra request?

    This too is really important because I like to minimize the number of requests made by my site as much as possible to increase the score in GTmetrix and Pingdom. BJ Lazy Load plugin doesn’t have any external request so it would be great to remove this external request.

    4. The last issue is related to the LiteSpeed Report Number. I tried sending the report but I got the following error: Failed to push to LiteSpeed server: LiteSpeedError Incorrect string value: '\xF0\x9F\x96\xA46\xEF...' for column 'env' at row 1.

    I am assuming that the issue is that I have the following header: Header set X-Emoji 🖤

    I would appreciate it if I could send my report to LiteSpeed with this header included.

    Thank you so much for your time and I hope to hear from you soon.

    The page I need help with: [log in to see the link]

Viewing 15 replies - 1 through 15 (of 16 total)
  • Plugin Support qtwrk

    (@qtwrk)

    Hi,

    1 and 2, what’s PHP log says about this error 500? also inside LSCWP there is a configuration for placeholder as well , does there give you 500 as well ?

    3, I think not possible to do this…

    4, that header is set at .htaccess file right ? I guess that’s the issue, may need to talk to dev about this …

    Best regards,

    Plugin Support qtwrk

    (@qtwrk)

    Hi,

    For 1 and 2 , we will need to know PHP log , that might tell us what’s going on.

    for 3, 4 , I will pass this to dev…

    Thanks.

    Best regards

    Hi @qtwrk

    Thank you for your quick reply.

    1 and 2: I just contacted my hosting provider and I will reply again when I have the logs.

    3 and 4: That would be fantastic.

    Thanks again for your time.

    Hi @qtwrk

    Here’s the PHP error:

    PHP Parse error: syntax error, unexpected ':', expecting ',' or ')'

    Plugin Support qtwrk

    (@qtwrk)

    Hi,

    Please check you php code since log says it’s syntax error.

    Best regards,

    Hi @qtwrk

    I did check the code.

    The code that I entered in my wp-config.php file was this one provided by @hailite

    define( 'LITESPEED_PLACEHOLDER', data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7' ) ;

    I wanted to try and set the placeholder from my wp-config.php but I couldn’t.

    Am I missing something?

    Plugin Support qtwrk

    (@qtwrk)

    Hi,

    When you see the error after you have added this string ?

    Try this

    define( 'LITESPEED_PLACEHOLDER', 'data:image/gif;base64,R0lGODlhAQABAIAAAAAAAP///yH5BAEAAAAALAAAAAABAAEAAAIBRAA7' ) ;

    it missed a

    before

    data

    Hi @qtwrk,

    Thank you. That did solve the problem.

    So now, 1 is solved.

    2, 3 and 4 are not yet.

    Is it possible to get a developer to reply to this ticket? That would be really appreciated.

    Plugin Author Hai@LiteSpeed

    (@hailite)

    2. Do you mean the notice of Compressing and resizing https://www.xx.com/…nt/uploads/2017/07/n47_atom_markdown.png could save 181.6KiB (93% reduction).?

    3. Maybe we need to give an option to Inline lazyload Lib too? Just same like Inline CSS Async Lib.

    4. Its because the report you sent includes non utf8 characters. Which plugin are you using to send the emoji header? We will try to reproduce locally.

    Hi @hailite,

    Thank you for your reply.

    2. Yes, that’s the notice I am referring to. But, please note that I do compress my images and I do use the plugin made by TinyPNG in order to do so.

    This notice does not appear when the plugin BJ Lazy Load plugin is enabled. It only appears when I use the LSCWP Lazy Load option instead.

    So, I am assuming that somehow the images still load and DO NOT lazy load in a Google PageSpeed test when the LSCWP Lazy Load option is enabled instead of the BJ Lazy Load plugin.

    3. That would be great. The fewer requests my site make the better.

    4. I don’t use any plugin. Just go to your .htaccess file, then write this:

    <IfModule mod_headers.c>
        Header set X-Emoji 🖤
    </IfModule>

    This should reproduce the issue.

    Thank you for your time and I hope to hear from you soon.

    Plugin Author Hai@LiteSpeed

    (@hailite)

    2. We will check it out and improve our lazy load if possible.

    3. Added to to-do list.

    4. Reproduced successfully. Thanks for feedback. Will debug and fix.

    That’s great.

    I look forward to future updates with these issues resolved.

    Thank you @hailite and @qtwrk for your help.

    Plugin Author Hai@LiteSpeed

    (@hailite)

    @music47ell

    4 is fixed. Please check.

    Hi @hailite,

    Thank you for the follow-up.

    I just checked 4 again and it did work.

    Report number is: PLYFGLDL

    Plugin Author Hai@LiteSpeed

    (@hailite)

    Just FYI, inline lazyload lib is done in https://github.com/litespeedtech/lscache_wp/commit/52c449dd711511bc815f582b48f696ced74b5af9

    Will be in v2.4.3 this week.

    Thanks.

Viewing 15 replies - 1 through 15 (of 16 total)
  • You must be logged in to reply to this topic.