Support » Plugin: SiteGround Optimizer » Lazy Load and Anchor links

  • Resolved willbode

    (@willbode)


    I have been trying to get the anchor links working for a long time. Some of them don’t go far enough (only on the first click). I have tried to disable lazy load using SG Optimizer for the whole page (I was unsure if I include the “.” for the class – I tried both with and without and can’t get it to work. It appears lazy load is still active and messing with my links… Please help.

    The page I need help with: [log in to see the link]

Viewing 7 replies - 1 through 7 (of 7 total)
  • Plugin Author Stanimir Stoyanov

    (@sstoqnov)

    SiteGround Representative

    Hey @willbode

    The anchor links are working along with the lazyload without any issues.

    Please provide more information if possible and we will check the issue again.

    Regards,
    Stanimir

    Thread Starter willbode

    (@willbode)

    here is a screen capture of what I am talking about. Most of them work most of the time. These two never work on first load. Any ideas?

    https://willbode.com/wp-content/uploads/2021/01/Screen-Recording-2021-01-20-at-11.26.06-AM.mp4

    Thread Starter willbode

    (@willbode)

    This is still not resolved. I don’t know why you marked it as resolved before you even gave me a chance to respond. I would appreciate help with this. Thank you. If not I will post again.

    Plugin Author Stanimir Stoyanov

    (@sstoqnov)

    SiteGround Representative

    Hey @willbode

    The problem is that the Elementor Anchor links calculate the position of the element on the page, and then scroll to that position.

    But, when the lazyload is enabled, we replace the original images with a placeholder. In your case, the placeholder height is smaller than the original image and the Elementor cannot calculate the correct position.

    If you open the following link: https://willbode.com/graphics/#ovensdiy108 the browser will scroll you to the correct section.

    So in this case you should disable the lazyloading or use another anchor-scroll widget.

    Marking as resolved, because there is an incompatibility between two plugins, not an issue with the lazyload.

    Regards,
    Stanimir

    Thread Starter willbode

    (@willbode)

    Ok to resolve it I had to disabled lazy-load by entering this code in functions.php

    add_filter( ‘wp_lazy_loading_enabled’, ‘__return_false’ );

    and then disabled and delete SG Optimizer and now it works.. Thanks for your help in resolving this issue!

    I hope that you will look into resolving this incompatibility in the future.

    • This reply was modified 10 months, 2 weeks ago by willbode.
    Plugin Author Stanimir Stoyanov

    (@sstoqnov)

    SiteGround Representative

    Hey @willbode

    Don’t get me wrong, I’ve just explained why the scroll is not working.

    You could use the Lazylaod exclude functionality to exclude the images from being lazyloaded.

    We have such interface and all you need to do is to add an exclude class name to all images and then add that class in the lazyload exclude field.

    Regards,
    Stanimir

    Thread Starter willbode

    (@willbode)

    I tried to disable lazy load from the entire page as you can see in the screen shot but it didn’t work.

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Lazy Load and Anchor links’ is closed to new replies.