Support » Plugin: MailPoet - emails and newsletters in WordPress » Layout problem with Google reCaptcha

Viewing 12 replies - 1 through 12 (of 12 total)
  • Plugin Author MailPoet


    Jarle, thanks for the screenshot and feedback. It’s been logged in our feedback list of items.

    Plugin Author MailPoet


    Thanks Jarle for the feedback. We’ve logged it in the feedback items to study in the future.

    We purposely used the compact version because it works every time on responsive layouts. We decided to not give a choice of display option because we strive to remove options to avoid bloat.

    I too have the same issue. A choice of compact or normal recaptcha on the Settings>Advanced tab would be great. The verticality of the compact recaptcha skews layouts. Google makes it mostly impossible to edit the look and feel of recaptcha.

    Please make this change in an upcoming version. This is not bloat this is design options.

    I agree with users above.
    It’s not bloat it gives plugin users the option to configure more things.


    I too have the Same Issue. A Display Option must be given.


    property “compact” must be optionally

    ver: 3.29.0
    edit plugin: assets\dist\js\public.70d9ace1.js
    replace: size:”compact” => size:””

    need a normal reCaptcha, compact broken custom form, plz

    The correct is to leave the default size and the person turns to modify pro compact if you want, usually use the default!

    I made simple code (jQuery) to normalize and leave at the default size.

    / Normalize Mailpoet Google Recaptcha Size   /
    / By: Husani Santos - /
    	$(window).on('load', function(){
    		var selector = $('.mailpoet_recaptcha iframe');
    		var gcaptcha = selector.attr('src').replace('size=compact', '');
    		selector.attr('src', gcaptcha);


    Can you tell me precisely when i need to put please ..

Viewing 12 replies - 1 through 12 (of 12 total)
  • The topic ‘Layout problem with Google reCaptcha’ is closed to new replies.