Support » Plugin: Multiple Columns for Gravity Forms » Layout Breaks When Updating

  • ResolvedPlugin Author WebHolism

    (@webholism)


    If you experience an issue with the form layout when updating to 3.1.0 – 3.1.2, it may be that you will need to go into the form and Enable CSS.

    Go to the form -> Form Settings -> Enable CSS and enable the checkbox beside Load CSS Stylesheet. Then click Update Form Settings.

    If you experience any other issues, please contact us at support and we will look into your issue.

Viewing 15 replies - 1 through 15 (of 15 total)
  • Hello,

    I’ve made that process but my row with 4 columns still got breaked.
    I had a row with 4 columns, I updated then activate Load CSS and Load JS, the form got better, but now I have 4 rows instead of 1 with 4 columns, it was working before the update.
    I have rpw start, content, break, content, break, content, break, content then row end

    Regards

    Hello,

    Another problem, if I have sections then it makes columns… Breaks the row.

    Regards,

    Plugin Author WebHolism

    (@webholism)

    Hi @zp,

    Our apologies for any inconvenience that may have been caused by the update.

    Please can you send an export of your form (https://docs.gravityforms.com/exporting-a-form-from-gravity-forms/) to hello@webholism.com?

    Thank you for your time and assistance.

    Kind regards.

    Hello,

    Email sent.

    Best regards,

    Plugin Author WebHolism

    (@webholism)

    Hi @zp,

    The issue that you were experiencing appears to be resolved in the 3.1.4 release. If you encounter any issues with that release or any other, please do not hesitate to bring it to our attention. šŸ™‚

    Thank you for your assistance in resolving the problem.

    Kind regards.

    Hi,

    I have updated to 3.1.4 but layout is still broken, also after updating the CSS settings for the form.

    Hope there is a fix..

    Regards, Tibor

    Update: viewing the page source it seems that there is no extra CSS loading on the front end.

    If I add the CSS from gf-form-multicolumn.css to my theme’s CSS it is fixed.

    Looking at the source code of the plugin, it seems the CSS is only being registered, but never enqueued.

    	public function enqueue_admin_preview_scripts( $styles, $form ) {
    		wp_register_style( 'preview_stylesheet',
    		                   plugins_url( '/public/css/gf-form-multicolumn.css',
    		                                __FILE__ ), array (), $this->_version );
    
    		return array ( 'preview_stylesheet' );
    
    	}
    
    Plugin Author WebHolism

    (@webholism)

    Hi @tibor,

    Thank you for taking the time to reach out regarding the plugin functionality, and sorry for the problem that is occurring with the CSS.

    Would it be possible to get an export of your form in a .json file format, so that we can examine the behaviour? If possible can you send an export of your form (https://docs.gravityforms.com/exporting-a-form-from-gravity-forms/) to hello@webholism.com?

    Thank you very much for your time and assistance.

    Kind regards.

    I have this plugin installed on MANY MANY sites and ALL of them are broken. Basically some CSS is not loading and I have already checked the CSS button to be on. I’ve had to manually override CSS to force a “float: left” on the

    • objects that are the columns. This is not a good long-term solution however, because your object model has a row # that causes the class name to be different each time, so I cannot just set _2 and _3 and _4 to be float:left across the whole site. Please fix this ASAP.

    I see you’ve just released 3.14 version but that one does not work either.

    Plugin Author WebHolism

    (@webholism)

    Hi @lifelightweb,

    We are sorry that you have been negatively impacted by the update to the plugin, that is never our intention.

    The naming convention of the rows and columns has remained the same between this version and the previous stable version (3.0.3), also there has been little change in the CSS file included. This makes understanding the cause of your issue a little difficult from first glance.

    Could you please provide an export of a form, or collection of forms (https://docs.gravityforms.com/exporting-a-form-from-gravity-forms/) that is/are experiencing this problem, and a Gravity Forms System Status report (https://docs.gravityforms.com/checking-environment-details/) to hello@webholism.com?

    We hope that we can then understand more clearly what the cause of this issue is.

    Please note that it is possible to access previous versions of the plugin at https://wordpress.org/plugins/gf-form-multicolumn/advanced/ while we investigate this problem.

    Your time and cooperation are greatly appreciated.

    Kind regards.

    Hi! I enabled the css but the columns don’t work on our website. Could you please help!

    Plugin Author WebHolism

    (@webholism)

    Hi @creative365,

    Many thanks for your contact, and sorry that the plugin is generating problems with your form layout.

    Could you please provide an export of your form (https://docs.gravityforms.com/exporting-a-form-from-gravity-forms/) that is experiencing this problem, and a Gravity Forms System Status report (https://docs.gravityforms.com/checking-environment-details/) to hello@webholism.com?

    We will then be able to provide more information.

    Your assistance is appreciated, and we hope to receive a response at your earliest convenience.

    Kind regards.

    There is a conflict between this plugin and the Essential Addons for Elementor that allow you to add a gravity form using their interface. When you switch to adding it as a straight shortcode, the columns on the form return.

    Plugin Author WebHolism

    (@webholism)

    Hi @mightyminnow,

    Thank you for the notification of this issue.

    We will investigate the problem and see if we can determine the cause. Then we can work on resolving it.

    If you have any further information on how to reproduce the problem it would be greatly appreciated. Please feel free to notify us at hello@webholism.com.

    Wishing you a marvellous day.

    Kind regards.

Viewing 15 replies - 1 through 15 (of 15 total)
  • The topic ‘Layout Breaks When Updating’ is closed to new replies.