• Resolved marilyn1998

    (@marilyn1998)


    I just updated to FooGallery 1.8.8. I have a gallery at the top and bottom of my home page. The bottom gallery is now coming up grey when the page is loaded. If I refresh, then it shows up. If I turn off lazy load on the bottom gallery it works as before. I have lazy load off right now, but I do have a screenshot.

    The page I need help with: [log in to see the link]

Viewing 14 replies - 1 through 14 (of 14 total)
  • I’m having a similar issue with a single gallery with lazy load activated. It will load x many photos, then the rest come up as grey boxes that are not interactable and no image will appear

    Plugin Contributor fooplugins

    (@fooplugins)

    Thanks for bringing this to our attention. We are working on fixing this issue and will have it sorted out as soon as possible.

    Plugin Contributor steveush

    (@steveush)

    Hi @marilyn1998,

    Could you please clear your cache and test again as the JavaScript being served from it for FooGallery is not the latest version.

    @dantianhealth without a URL there is not much I can do except say try clearing your cache as well.

    Thanks

    Hi Steve
    All caches are actually currently disabled (production site). I have also cleared my browser cache and tried across various browsers (mainly shows up on mobile device due to more images being out of viewport). I was using responsive gallery, have switched to a different gallery but same result.
    https://www.asc.dantianhealth.com.au/shiatsu-college/

    Plugin Contributor steveush

    (@steveush)

    Hi @dantianhealth,

    Thanks for the URL update. I think I have found the issue in the method that determines the parent scrollable container that FooGallery binds its lazy loading to. Basically at the moment due to a combination of how this method determines the element and your themes CSS FooGallery is binding lazy loading to your <body/> instead of the <html/> so it never triggers the additional loading of images on scroll.

    I’ll create a fix for the issue I am seeing and will get back to you once I’ve had a chance to test it a bit more.

    Also unfortunately this issue will affect lazy loading across all templates as its code is shared between them.

    For now I would temporarily disable lazy loading until the fix is available to ensure all images are loaded on your site.

    Thanks

    Ok thanks
    If it helps you to know, i have only recently installed the plugin (2-3 days) and I swear that lazy loading worked fine initially!

    FYI I have tried this on a staging site with a different theme (astra) and disabling most other plugins and still get the same issue

    Thank you. I have cleared all caches, browser, etc. disabled lazy load as requested. I am using responsive on footer and simple portfolio in below header.
    I am also on iPad Pro. URL is https://www.marilynstreats.com/ thx

    Similar problem here, after updating images appear greyed out. I cleared all caches, css cache, whatever. Still it does not work anymore.

    Example url:
    https://www.raffaellarivi.net/video-scenografie/

    Thank you
    sergio

    Plugin Author bradvin

    (@bradvin)

    hi @marilyn1998, @sergiomarchesini, @dantianhealth

    Please can you download v1.8.9 from this link : https://we.tl/t-UetnZsXoqV

    Deactivate your existing version of FooGallery and install this new version, which includes a fix for the lazy load issues you are seeing.

    Please let us know if that solves your problem

    Hi @bradvin,
    Thanks for that, but I’m sorry to say that I am still having the same issue. I have ensured full cache flushes etc but am getting the same result.
    EDIT: I then proceeded to exclude ‘foo’ from inline script merging in SwiftPerformance plugin and it worked (previously disabling swift was not a fix). Now it appears to be working!
    I do have an issue appearing now if I enable lazy loading in swift to capture other images outside of foo that results in a similar issue as we have been dealing with reappear, seems there is no easy out!

    • This reply was modified 5 months, 3 weeks ago by Jason Chong.

    Deactivated Foo. Cleared all caches. Uploaded 1.8.9 it failed. I tried 3 times and failed upload. Reactivating 1.8.8 and turned off lazy load. What next? Thx.

    Plugin Author bradvin

    (@bradvin)

    @marilyn1998 what was the error when the upload failed?

    Plugin Support phillcoxon

    (@phillcoxon)

    Hi @marilyn1998, @dantianhealth, @sergiomarchesini,

    Updating to the latest version of FooGallery should have resolved each of the issues you were experiencing.

    I’m going to assume this is the case as you haven’t responded again for a week and so I’ll mark this support request resolved.

    If you need any additional assistance would you please open a new support request so we can help you?

    Thanks!

Viewing 14 replies - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.