Support » Plugin: Plugin Name: ads-WpSiteCount » läuft nicht unter PHP 7.4?

  • Resolved lethert

    (@lethert)


    Ich nutze das Plugin schon lange und war immer sehr zufrieden damit. Seit dem Update unserer WebSite auf PHP 7.4 läuft wordpress auf einen Fehler. Wenn ich das Plugin dann deaktiviere funktioniert die WebSite wieder einwandfrei…

    Bitte das Plugin mit der Version 7.4 kompatibel machen. Danke.

Viewing 11 replies - 1 through 11 (of 11 total)
  • Zusatzinfo: Auf der WebSite ist auch WP Super Cache im Einsatz.
    DAS hat aber in der Vergangenheit keinen Einfluss auf die Funktionsfähigkeit von ADS-WpSiteCount gehabt.

    Plugin Author Andrew

    (@adespont)

    Guten Tag
    Leider habe ich keinen PHP 7.4 Server zur Verfügung zum Testen.
    Sorry

    Das wird sich ja sicherlich irgendwann ändern…
    Alternativ könnte man dem z.B. mit Laragon https://laragon.org/ aufsetzen, falls Sie mit Windows arbeiten.
    Kann ich evtl. irgendwie beim Testen helfen?

    Plugin Author Andrew

    (@adespont)

    Hi @lethert
    Danke für die Hilfe.
    Ich habe Laragon installiert auf Win10 danach das PHP 7.4.5 upgrade und im Menu aktiviert

    Darauf eine WordPress installation und alle meine Plugins darauf installiert.
    Alles läuft ohne Probleme mit 7.2.x UND 7.4.6 (max)
    Auch eine benutzte Seite mit Datenbank importiert.
    Soweit ich sehen kann sind alle meine Plugins PHP 7.4.6 tauglich.
    Wordpress habe ich die neuste Beta genommen: Entwicklerversion 5.5-alpha-47800.

    Somit wird das wohl woanders liegen oder etwas beißt sich.

    Liebe Grüsse
    Andrew

    Danke für die Rückmeldung. Ich habe auf den Seiten ja noch WP SuperCache im Einsatz.
    Ich werde mal austesten, ob es daran liegt. Der Fa. tritt blöderweise nicht sofort auf… d. h. da könnte evtl. schon der Cache dran Schuld sein.

    Ich versuche das weiter zu analysieren und gebe hier nochmals Rückmeldung.

    Plugin Author Andrew

    (@adespont)

    Können Sie den Debugger aktivieren (wenn möglich nur vom betroffenen Plugin) und mir das Debugprotokoll vom Plugin zustellen? Würde mir evtl. weiterhelfen.

    Danke

    weiter analysiert:
    * WP SuperCache deaktiviert – keine Änderung
    * PHP 7.3 ok
    * PHP 7.4 danach wichtig:
    Cahches leeren, sowohl von SuperCache als auch vom Browser
    — Fehler tritt konstant auf
    * ADS-WpSiteCount deaktiviert – Fehler weg
    * PHP 7.3 aktiviert
    Plugin aktiviert
    Fehler noch da
    Caches geleert
    Fehler weg, läuft mit 7.3 wieder sauber

    weiter analysiert:
    debug in WP gesetzt mit Version 7.4 analysiert:
    Fehlermeldung:

    Fatal error: Uncaught Error: Call to undefined function imagecreatefromjpeg() in /pages/57/75/d0012438/home/htdocs/DVKoeln/wp-content/plugins/ads-wp-site-count/ads_wpsitecount.php:292 Stack trace: #0 /pages/57/75/d0012438/home/htdocs/DVKoeln/wp-content/plugins/ads-wp-site-count/ads_wpsitecount.php(183): adswsc_MakeImage(‘705758’, 5, ‘on’, ‘off’, ‘flippingnumbers…’, 250) #1 /pages/57/75/d0012438/home/htdocs/DVKoeln/wp-content/plugins/ads-wp-site-count/includes/ads_shortcode.php(88): adswsc_GetViewCounter(0, Array) #2 /pages/57/75/d0012438/home/htdocs/DVKoeln/wp-content/plugins/ads-wp-site-count/includes/ads_shortcode.php(48): adswsc_clsShortCode->post_function(Array) #3 /pages/57/75/d0012438/home/htdocs/DVKoeln/wp-includes/shortcodes.php(343): adswsc_clsShortCode->post_handler(Array, ”, ‘ads-wpsitecount’) #4 [internal function]: do_shortcode_tag(Array) #5 /pages/57/75/d0012438/home/htdocs/DVKoeln/wp-includes/shortcodes.php(218): preg_replace_callback(‘/\\[(\\[?)(ads\\-w…’, ‘do_shortcode_ta…’, ‘<h1 style=”text…’) # in /pages/57/75/d0012438/home/htdocs/DVKoeln/wp-content/plugins/ads-wp-site-count/ads_wpsitecount.php on line 292

    weiter analysiert:
    PHPinfo der Version 7.3 und 7.4 beim Provider (Strato Managed Server)
    Scheinbar hat Strato bei PHP 7.4 im Bereich GD die JPEG Unterstützung nicht mit eingebunden. Bleibe dran, habe hier schon eine Anfrage am Laufen, melde mich, wenn ich aktuelle Infos habe.

    Plugin Author Andrew

    (@adespont)

    Ok Danke. Ja ohne JPEG Untersützung funktioniert das Tool nicht.
    Dann sollte es ja dann funktionieren…

    Gibt noch ne neue Version, habe noch “Unschönheiten” gefunden.
    Grüsse

    • This reply was modified 4 months, 1 week ago by Andrew.
    Plugin Author Andrew

    (@adespont)

    Tested with:
    WordPress : 4.x to 5.5
    PHP : 5.6 to 7.4.6
    MariaDB : 5.7.30-0ubuntu0.16.04.1-log – (Ubuntu)
    MariaDB : 10.4.11-MariaDB – xampp

Viewing 11 replies - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.