Support » Plugin: Watu Quiz » Latex not displaying properly in multiple choice answers

  • Resolved autarkaw

    (@autarkaw)


    Hello:
    Putting latex works in the question statement of a multiple choice question, but
    1) when used in the multiple choices, it does not align properly. See the link – https://numericalmethods.autarkaw.com/quiz-publish/.
    2) click on submit and the answers do not show up the latex part properly.

    Any help would be appreciated.

    The page I need help with: [log in to see the link]

Viewing 3 replies - 1 through 3 (of 3 total)
  • autarkaw

    (@autarkaw)

    I got this from Katex support and it worked for Q1. I still need help on Q2.

    It’s a CSS problem. One of the CSS files is ‘https://numericalmethods.autarkaw.com/wp-content/plugins/watu/style.css?ver=2.3.1’ and it contains the following rule:

    .answer span {
    padding-right:20px;
    }
    That rule selects every span that is a descendant of class answer and applies 20px of right padding to each individual span. Instead of a .answer span selector, it should use a .answer>span selector. Then only the direct descendant would get that 20px padding and the more deeply nested KaTeX descendant spans would all be rendered properly.

    Plugin Author prasunsen

    (@prasunsen)

    Answers are loaded with Ajax. You should either use a Latex plugin which works fine in Ajax called page or switch off Ajax from Watu Settings page.

    autarkaw

    (@autarkaw)

    Switching of Ajax worked.

    Just pointing this for other readers – Under WATU settings, go to “ajax in Quiz” and then check mark the quizzes in “The selected quizzes will NOT use Ajax when users submit them.” Thank you!

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.