Support » Plugin: Post Affiliate Pro » Latest WordPress (5.2.2)/WooCommerce(3.6.5) is not supported

  • We deactivated all plugins except WooCommerce and Post Affiliate Pro (PAP). We switched to the default Twenty Seventeen theme. We have tried using the default PapApi.class.php that came with the plugin, and the same file downloaded from the PAP website. In all cases clicks are tracked but sales are not tracked, hence PAP is currently useless.

    We are subscribers to the paid version, and have reported our findings to PAP support. We have not received any useful support as yet. The error message is provided below.

    Can anyone shed any light on this error and how to fix it?

    
    Notice: id was called incorrectly. Order properties should not be accessed directly. Backtrace: require('wp-blog-header.php'), require_once('wp-includes/template-loader.php'), include('/themes/twentyseventeen/page.php'), get_template_part, locate_template, load_template, require('/themes/twentyseventeen/template-parts/page/content-page.php'), the_content, apply_filters('the_content'), WP_Hook->apply_filters, do_shortcode, preg_replace_callback, do_shortcode_tag, WC_Shortcodes::checkout, WC_Shortcodes::shortcode_wrapper, WC_Shortcode_Checkout::output, WC_Shortcode_Checkout::order_received, wc_get_template, include('/plugins/woocommerce/templates/checkout/thankyou.php'), do_action('woocommerce_thankyou'), WP_Hook->do_action, WP_Hook->apply_filters, postaffiliatepro_Form_Settings_WooComm->wooAddThankYouPageTrackSale, postaffiliatepro_Form_Settings_WooComm->trackWooOrder, WC_Abstract_Legacy_Order->__get, wc_doing_it_wrong Please see Debugging i in /home/tra/public_html/wp-includes/functions.php on line 4773
    

    Thank you in advance for any help or advice.

    • This topic was modified 6 months, 3 weeks ago by Jan Dembowski.
Viewing 1 replies (of 1 total)
  • Plugin Author qusupport

    (@jurajsim)

    Hello, your request has been processed = the issue has been fixed an the new version with fixes will be release shortly.
    Thank you for your patience.

Viewing 1 replies (of 1 total)
  • The topic ‘Latest WordPress (5.2.2)/WooCommerce(3.6.5) is not supported’ is closed to new replies.