Support » Plugin: SVG Support » Latest Version (v2.3.14) does not work with Astra Theme!

  • Resolved Farbweiss

    (@farbweiss)


    Hello,
    unfortunately I had to roll back to v2.3.12 – because latest version v2.3.14 does not work with Astra Theme (check out for yourself – its this one: https://wordpress.org/themes/astra/).
    What is the problem? I can upload a SVG, but if I want to add it to a page, it will not show up (setting SVG to 1×1 pixel). Also in the customizer for Logo it does not work. Rolling back to v2.3.12 solved it – SVG came back in normal size

    I tried with Twentyseventeen Theme – and it worked normal in latest version. Needless to say, I tried with disabled plugins. So there must be an incompatibility with latest version.

    Please check out if you can find the error. Astra Theme is quite popular theme – many are using it. If you need, I can send you login credentials for a DEV site with astra.

    • This topic was modified 1 year, 9 months ago by Farbweiss.
Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Benbodhi

    (@benbodhi)

    Hi @farbweiss,

    Thanks for your support and pointing this out!
    This is the second report of issues with that particular code.
    I have changed it in version 2.3.15 to fix your issue as it’s just a single word that makes the difference. I changed it to fix some PHP warnings that would show, but it caused more issues than warnings in the fix. So I have rolled that particular change back and will work on a new solution for the other issue.

    Related post: https://wordpress.org/support/topic/update-not-working-with-beaver-builder/

    Thank you very much. Regarding the php warnings (if using an SVG in Image widget)… I was able to get around this by leaving the image size empty. So go to image settings, choose “individual size” und leave both (height / width) empty. Save the widget. Then the error is not there. Of course you need an extra CSS styling for this now – so to set height and width correct 🙂
    Anyway I wish you good luck with the problem! Have a nice day.

    Plugin Author Benbodhi

    (@benbodhi)

    Thanks for pointing that out. I’ll aim to avoid any workarounds, but it’s super helpful to understand exactly what happens and how. Very appreciative of your time to provide feedback. Thank you 🙂

    Have a great day!

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Latest Version (v2.3.14) does not work with Astra Theme!’ is closed to new replies.