Support » Plugin: CM Tooltip Glossary » Latest version upgrade broke site

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author CreativeMinds

    (@creativemindssolutions)

    Hi yakos,

    Sorry to hear about your problem – please check the PHP version – there’s a chance that the problems are because your server is using a very old PHP 5.2 which lacks some of the cool features of the newer version of the PHP.

    Best,
    Marcin

    Hi Marcin,

    Thanks for the information and for replying promptly.
    Here are the versions for WP and PHP

    WordPress 4.4.2
    Running PHP version: 5.4.43

    Is that good enough for CM Tooltip ?

    thnks
    yakos

    Hi Marcin,

    Trying to go to version 3.3.3 of CM Tt I got this Parse error now-

    Parse error: syntax error, unexpected T_STRING in /xxxxxxxx/public_html/wp-content/plugins/enhanced-tooltipglossary/package/cminds-free.php on line 3

    thanks

    Plugin Author CreativeMinds

    (@creativemindssolutions)

    Hi yakos,

    It should be enough, the functionality which is used in the line in question was introduced in PHP 5.3 so it should work good in PHP 5.4.43. I didn’t find any traces of the known bugs related to that also.

    Still my best quess is that’s the problem with the PHP version – could you try to switch it to some other PHP version higher than 5.3?

    Thanks,
    Marcin

    Hi Marcin,

    I really don’t understand. The server here is running PHP 5.4.43 and you’re telling me that it should be fine with a version over PHP 5.3

    Well, clearly this version is higher than 5.3 and its failing. Don’t you think that good code should work with all latest versions?

    Is there a way for me to hack it so that I can get it working and away from the fatal error?

    thanks

    Plugin Author CreativeMinds

    (@creativemindssolutions)

    Hi yakos,

    I mean it may be an unknown bug in this particular version of the PHP, that’s why I asked if it’s possible for you to check any other PHP version > 5.3.0.

    There’s a similar topic where users had exactly the same problem – namespaces weren’t working despite the PHP version > 5.3.0 – turned out that the users were mislead: https://wordpress.org/support/topic/fatal-error-upon-updating?replies=43

    I’m 99% sure it’s the problem with PHP version.

    Best,
    Marcin

    Thank you Marcin,

    And thanks for the great plugin. We will keep battling with this error.

    best regards
    Yakos

    Getting the same error. PHP 5.4 installed on server.

    Actually, I take it back. I thought my server was 5.4, but it was actually 5.2.17. Updated to PHP 5.4.45 and this plugin is back in business.

    Hello. I’ve got the same problem after upgrading CM ToolTip. Is it not possible to block the upgrade when the PHP version is too old?

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Latest version upgrade broke site’ is closed to new replies.