Support » Plugin: WP-Ban » latest version of wp-ban breaks after 4.3 update

Viewing 15 replies - 16 through 30 (of 31 total)
  • May be w3 total cache affected that

    Plugin Author Lester Chan

    (@gamerz)

    @lawfather, @shanebkk 1.66 supposed to fix it, I can’t reproduce the problem anymore on my end.

    Download the zip file and extract the zip and upload the files to /wp-content/plugins/wp-ban/ if you are still having problem. Also clear your cache if you have. If you are using HHVM, sometimes the JIT caches the PHP file as well.

    uploaded it again, version 1.66 installed, clear chache on site and on browsers,

    working fine from Search engines

    not working direct typing of wesprayanything.com

    Plugin Author Lester Chan

    (@gamerz)

    Check your error logs.

    godaddy managed wordpress, no access to error logs

    shanebkk,

    Your problem will most likely be due to script caching (PHP memory caching). I believe this is one of the major issues with running WordPress on Godaddy. Freelancing Care is partly correct.

    You can either choose to be patient and wait for the memory caching to wear off, switch to a VPS solution, or ask Godaddy to reset the cache or soft restart their webserver daemon.

    You mentioned btw that you had accessed the site via FTP.

    Also, the “without www” issue can be resolved by (implies you already enabled rewrite in .htaccess and this should be entered in the beginning just after “Options Rewrite On”):

    RewriteCond %{HTTP_HOST} ^yourdomain\.com
    RewriteRule ^(.*)$ http://www.yourdomain.com/$1 [R=permanent,L]

    I have GoDaddy managed WP. I cannot access themes in the dashboard. I get

    Fatal error: Cannot redeclare get_language_attributes() (previously declared in /home/content/p3pnexwpnas02_data02/47/2604047/html/wp-includes/general-template.php:2624) in /home/content/p3pnexwpnas02_data02/47/2604047/html/wp-content/plugins/wp-ban/wp-ban.php on line 249

    Get this same error when typing in my address in chrome, and when searching in google and clicking on link.

    I don’t have ftp access. How do I fix this? I’d take spam bots over broken any day.

    @webbvt If you have a godaddy managed wordpress a/c, you have access to your FTP, go to a/c settings, manage hosting, click on the FTP site settings, under settings, go to SSH and all your access will be there, just toggle the password. Once you have access, uninstall the WP – Ban plugin,

    you will then regain access to the a/c via WP-admin

    My site got infected with spam due to this error, so you will have to check to see if your site is now listed as a spam site

    @shanebkk Thanks for the nudge in the right direction. Through SFTP, I was able to disable WP-Ban.

    Now how do I find out if my site has been listed as spam site? That sounds horrible.

    I’m getting this error as well and don’t have the skill or tools to change anything via an FTP and commenting. Is the extension going to be fixed? I can’t access my site at all at this point.

    StillSane2014,

    You will have to get help for this then. FTP or Shell access is required.

    Since your WP site is completely broken due to the bad plugin, no update will happen until thw faulty function in wp-ban.php is removed (or the faulty plugin version is removed manually by FTP).

    Plugin Author Lester Chan

    (@gamerz)

    @stillsane2014: it is already fixed, but you need FTP access to overwrite the files.

    Download https://downloads.wordpress.org/plugin/wp-ban.1.66.zip and extract it, use your FTP and overwrite your files in your server /wp-content/plugins/wp-ban/

    Thanks Lester Chan for the fix!

    I updated the plugin wp-ban as per suggested by @lester and i got the solution. Thanks @lester

    MarcoSantarelli

    (@marcosantarelli)

    Hi @lester,

    I downloaded the Zip file and replaced the PHP file as you instructed. However that did not fix the error:

    Plugin could not be activated because it triggered a fatal error.

    Fatal error: Call to undefined function get_language_attributes() in D:\domains\noradarealestate.com\wwwroot\Blog\wp-content\plugins\wp-ban\wp-ban.php on line 287

    Please advise.

    Thank you!

Viewing 15 replies - 16 through 30 (of 31 total)
  • The topic ‘latest version of wp-ban breaks after 4.3 update’ is closed to new replies.