WordPress.org

Support

Support » Plugins and Hacks » [Resolved] Latest version gives problems and not working

[Resolved] Latest version gives problems and not working

Viewing 13 replies - 1 through 13 (of 13 total)
  • KWhite
    Blocked

    @crunchydata

    The latest update crashed our site. We had to rename the plugin via FTP to get the site back up.

    New version not working after update, getting permission error no matter what permissions or owners I use, tried deleting the plugin completely and reinstalling it from scratch, tried the empty file, tried deleting the file and having plugin re-create it and I always get this same error message and viewing page src, the plugin is not running

    Failed to update your /wp-content/advanced-cache.php file. Most likely a permissions error. Please create an empty file here: /wp-content/advanced-cache.php (just an empty PHP file, with nothing in it); give it permissions 644 or higher (perhaps 666). Once you’ve done this, please try again.

    Carlos Revilla
    Member

    @carlos-revilla

    I also had to deactivate the plgin via FTP

    Gives me the following error

    “Fatal error: Exception thrown without a stack frame in Unknown on line 0”

    Carlos

    Plugin Author WebSharks
    Member

    @websharks

    Hi there 🙂 Sorry to hear you’re having trouble.

    I have not been able to reproduce this in our lab. I noticed in this screenshot that the Quick Cache admin panel is not loading the required CSS file either (e.g. this page is totally unstyled in your Dashboard).

    Have you tried reproducing this w/ a clean (default) WordPress installation yet?

    Plugin Author WebSharks
    Member

    @websharks

    Screenshot where the admin panel is unstyled.

    View post on imgur.com

    sarangan112
    Participant

    @sarangan112

    What do you mean by clean WordPress? I already used Quick Cache plugin in years at that website. My site is hosted at one.com servers, all WP sites have the same problem on that server. Not on CSS also the plugin will be not be activated and nothing works.

    Plugin Author WebSharks
    Member

    @websharks

    By “clean”; I mean to say “default” WordPress installation running only the Quick Cache plugin and a default theme. I was unable to reproduce the bug you reported here, so I’d like to find out more.

    What does your current environment look like? Other themes/plugins?

    sarangan112
    Participant

    @sarangan112

    It’s sad such a good and most famous plugin was released without tested much on all kind of server platforms. Also you have removed the clear cache button from top of admin panel and added that in pro version to earn money! It’s okay.

    Even I loved your plugin, i’m forced to move to another WP cache plugin.

    Bye Quick Cache!

    sarangan112
    Participant

    @sarangan112

    The problem was.. The file /wp-content/plugins/quick-cache/client-s/css/menu-pages.min.css was blocked by the .htaccess file you have in /quick-cache/ folder. My hosting company server (CGI/FastCGI) doesn’t supports “Options -Indexes”. My hosting blocks the directory listning by default and it was the problem. Simply removing the .htaccess file helped the CSS issue.

    # Configuration of directory indexes.
    # For added security (set these explicitly).
    Options -Indexes
    DirectoryIndex index.php
    sarangan112
    Participant

    @sarangan112

    I will suggest you to delete the .htaccess file by default. If you release a newer version, it will broke my site again and I need to delete that .htaccess file everytime I update the plugin.

    2. The another error is still there:

    The plugin generated 176 characters of unexpected output during activation. If you notice “headers already sent” messages, problems with syndication feeds or other issues, try deactivating or removing this plugin.

    This is too bad. I use a site management tool to keep all my sites updated. I unfortunately updated this plugin on all 27 of my sites and it brought them all down. Spent the morning manually removing the plugin.

    My fault for not testing on one first. Which I know and didn’t follow, my bad. Certainly won’t happen again. But this update still shouldn’t cause a catastrophic failure like this. Now that I’ve uninstalled it from all my sites…not likely I’ll be putting it back.

    Too bad it had been a great plugin.

    Plugin Author WebSharks
    Member

    @websharks

    @sarangan112 Thanks for reporting this 🙂
    I’m filing a bug report here so we can take a closer look at this before the next update. https://github.com/WebSharks/Quick-Cache/issues/9

    Plugin Author Raam Dev
    Participant

    @raamdev

    @sarangan112 The bug you reported has been fixed in the latest version of Quick Cache (v131206). See also: https://github.com/WebSharks/Quick-Cache/issues/9

    @webovative @msqinc @crunchydata @carlos Revilla I apologize for the trouble. The latest version of Quick Cache contains better compatibility-checking routines that should prevent issues like those you experienced. Please let me know if you’re still experiencing issues with the latest version of Quick Cache (v131206).

Viewing 13 replies - 1 through 13 (of 13 total)
  • The topic ‘[Resolved] Latest version gives problems and not working’ is closed to new replies.