Support » Plugin: Mailjet Email Newsletter Marketing » Latest version forces site language to US English

  • Resolved chrisgot

    (@chrisgot)



    Hi, thanks for your great service. Seems there is a problem with this plugin causing the site language under general settings to force US English in the admin area. I have the site running in Swedish, and it’s fine when Mailjet for Wordress is deactivated. As soon as I activate the plugin the site language is set to US English and when I try to change to Swedish, which is listed as installed, it snaps back to US English when I press save. All was fine before latest update.

    https://wordpress.org/plugins/mailjet-for-wordpress/

Viewing 10 replies - 1 through 10 (of 10 total)
  • Just to confirm, I have re-installed 3.2.3 and the site language is correct and everything works fine.

    Plugin Author Mailjet

    (@mailjet)

    Hello,

    Thank you for using Mailjet and for notifying about the issue that you have faced.

    We will investigate it and come back to you. What plugin are you using for change site’s language?

    Thank you,

    Mailjet team

    Hi. Thank you for your reply. I don’t use any translation plugin. To change site language navigate to Settings > General > Site Language in WordPress admin area. This is part of WordPress core since 4.0 – see https://codex.wordpress.org/Installing_WordPress_in_Your_Language
    The Site Language setting in the admin area is where the language snaps back to English (US) when I try to save it to Swedish – happens only when the latest version of Mailjet for WordPress is installed. I never changed the language from Swedish, it happened by itself when Mailjet was updated to 3.2.4.
    My original WordPress install is in Swedish language.

    I just checked the locale use by Mailjet for WordPress. In version 3.2.4 the locale variable is globalized, which is what causes the language to be forced to English, since I also don’t use WPLANG (deprecated) any more in wp-config file. Is there any reason for globalizing $locale? By simply commenting out line 18 (//global $locale;) in the file mailjet-class.php my admin language is correct again – in Swedish.

    Plugin Author Mailjet

    (@mailjet)

    Hey Chris,

    Thank you for those further details.

    We are currently testing a fix available on our development branch in GitHub – https://github.com/mailjet/wordpress-mailjet-plugin-apiv3/tree/development

    Once we release, I’ll notify so you can use properly our latest version.

    Thanks,

    Mailjet team

    Cool, encounter the same problem.

    Plugin Author Mailjet

    (@mailjet)

    Hello,

    We release a new version of our plugin :
    https://wordpress.org/plugins/mailjet-for-wordpress/

    Could you please test on your end?

    Thanks,

    Mailjet team

    Working, thanks!

    Plugin Author Mailjet

    (@mailjet)

    Thanks,

    We will close this topic but we remain at your disposal, if you have any questions or comments,

    Regards,

    Mailjet team

    Thanks for the quick fix!

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Latest version forces site language to US English’ is closed to new replies.