Support » Plugin: WordPress Persistent Login » Latest version breaks some sites

  • Resolved harryfear

    (@harryfear)


    Hi,

    The latest version seems to break some sites. I have 3 sites all error 500 on wp-admin after login.

Viewing 11 replies - 16 through 26 (of 26 total)
  • Plugin Author lukeseager

    (@lukeseager)

    Thanks for the update @harryfear, I’ll keep an eye on that thread too.

    I’ll send my query to that email address to see if they can help. I’ll also test the setting they mention in the Wordfence thread to see if that is the cause of the issue.

    Thread Starter harryfear

    (@harryfear)

    Hi Luke,

    As there is a third plugin involved, I looked at its latest versions.

    The last couple of builds of Admin Menu Editor present the fault.

    But v1.9.6 doesn’t cause the issue – while v1.9.7 does. So I did a changes comparison of the ZIPs.

    The changes are not extensive as I can see. They may provide further clues to you as to what’s going wrong.

    I put the text comparison report here:
    http://wppldemo.duckdns.org/wp-content/uploads/2022/03/Text-Compare.html

    Also available an an image.

    Again, it seems to point to WordFence losing its head over user roles/rights/privileges/etc.

    I’m over my head here but just throwing anything over in the hope it helps 🙂

    Best,

    Harry.

    Plugin Author lukeseager

    (@lukeseager)

    Hi @harryfear,

    This is great stuff, thank you.

    I agree that the issue is likely wordfence being over protective, however it’s comforting to know it’s doing its job, even if a little too well.

    I’ll look into the admin menu changes to see if there’s anything relevant in there and report back.

    Thread Starter harryfear

    (@harryfear)

    Hi Luke,

    They now say that “genbiz @ wordfence . com” is the email address to work on whitelist/hotfix/collab!

    https://wordpress.org/support/topic/error-500-from-wordfence-with-2-plugins/#post-15500218

    Thread Starter harryfear

    (@harryfear)

    This issue is still persisting.

    Plugin Author lukeseager

    (@lukeseager)

    Hi Harry, this issue is still on my radar and is being looked into. Apologies for the delay.

    Thread Starter harryfear

    (@harryfear)

    Had the same issue suddenly recur on a different/new site recently (when it auto-updated to latest versions of the plugins). Presented again as white-page 500 error.

    Muscle memory said to wipe the admin menu editor plugin, which solved the issue!

    Still strikes as bizarre this incompatibility triangle.

    Hope well. Any news from WordFence? No reply to my comms.

    Plugin Author lukeseager

    (@lukeseager)

    Hi Harry,

    It is a strange combination of issues. I’m not having much luck my end, Wordfence have only given me a very basic response, I don’t think it’s been given to a developer to have a look at unfortunately.

    This is still on my radar! I do apologies for how long it’s taking to resolve.

    Thread Starter harryfear

    (@harryfear)

    This now issue seems resolved on these versions:
    Admin Menu Editor – Version 1.10.2.
    Wordfence Security (wordfence) – Version 7.5.10.
    WordPress Persistent Login (wp-persistent-login) – Version 2.0.5.

    For posterity, the problem was present on these versions in combination:
    Admin Menu Editor – Version 1.9.7.
    Wordfence Security (wordfence) – Version 7.5.9.
    WordPress Persistent Login (wp-persistent-login) – Version 2.0.0.

    Thread Starter harryfear

    (@harryfear)

    I spoke to soon. This issue still persists. Error 500 once you log out and log in again.

    I just tried it on a test site and seeing this behavior as well.
    And I have admin editor/wordfence combo as well.

    • This reply was modified 2 months, 1 week ago by sbask.
Viewing 11 replies - 16 through 26 (of 26 total)
  • You must be logged in to reply to this topic.