Support » Plugin: Enlighter - Customizable Syntax Highlighter » Latest version 4.4.0 breaks the website

  • Hello, guys!

    I’m getting the following error after I update the plugin:

    Parse error: syntax error, unexpected ‘)’ in */wp-content/plugins/enlighter/modules/core/Enlighter.php on line 98

    I couldn’t access the Dashboard anymore and had to delete the plugin (e.g. via SFTP or the website’s panel offered by the hosting company) and rollback to the previous version.

    Please fix it as anyone who already made the update had the same problem and made the website non-functional!

    Regards,
    Gabe

Viewing 14 replies - 1 through 14 (of 14 total)
  • After updating the plugin, any page in the back-end gave me:

    There has been a critical error on your website. Please check your site admin email inbox for instructions.

    Thread Starter Gabe Livan

    (@gabelivan)

    @noyle yes, it’s the same error but it didn’t print on the screen in your case. WordPress just mentioned there’s a problem. It’s very likely you received an email and you have the error’s details there.

    @gabelivan I don’t receive the mail yet and have to check the server log later in this day. But thanks for letting me know the probable error details!

    Edited: I brought the site up by deactivating this plugin.

    • This reply was modified 5 months, 4 weeks ago by noyle.

    same problem after updating to 4.4.0. switched back to previous version for now until a fix.

    Parse error: syntax error, unexpected ‘)’ in /home/snourian/public_html/wp-content/plugins/enlighter/modules/core/Enlighter.php on line 98

    huge thanks for this great plugin.

    • This reply was modified 5 months, 4 weeks ago by nrsina.
    Plugin Author Andi Dittrich

    (@andi-dittrich)

    i’ll check this asap, sry!

    Plugin Author Andi Dittrich

    (@andi-dittrich)

    what PHP versions are you using ? i see what’s going wrong but no lint warning or errors have been raised in the testing environment – it’s a bit strange

    a fix will be released asap

    PHP 7.2.34 here (experiencing the same issue)

    Thread Starter Gabe Livan

    (@gabelivan)

    PHP 7.2.34 as well!

    Same issue on my FreeBSD-machine

    meister@wordpress / % php -v
    PHP 7.2.34 (cli) (built: Oct 10 2020 01:14:37) ( NTS )
    Copyright (c) 1997-2018 The PHP Group
    Zend Engine v3.2.0, Copyright (c) 1998-2018 Zend Technologies
    meister@wordpress / % php-fpm -v
    PHP 7.2.34 (fpm-fcgi) (built: Oct 10 2020 01:14:44)
    Copyright (c) 1997-2018 The PHP Group
    Zend Engine v3.2.0, Copyright (c) 1998-2018 Zend Technologies

    PHP 7.2.24

    Plugin Author Andi Dittrich

    (@andi-dittrich)

    thanks!

    Just downloaded your edits from GitHub. The plugin is now working.
    Good work, thanks a lot!

    Plugin Author Andi Dittrich

    (@andi-dittrich)

    great!
    i’m very sorry for this inconvenience. version v4.4.1 is out including the fix.

    to avoid such issues in the future, the lint checks are now performed via travis-ci against php5.6/7.0-7.4 – https://travis-ci.org/github/EnlighterJS/Plugin.WordPress/jobs/736859527

    the broken version has been purged

    Thank you very much! 🙂

Viewing 14 replies - 1 through 14 (of 14 total)
  • You must be logged in to reply to this topic.