Support » Plugin: Fast Velocity Minify » Latest updates causing 403

  • Resolved George

    (@subscriptiongroup)


    After today’s changes (v2.8.5 onwards i think) we started experiencing 403 errors on various requests including /?wc-ajax=update_order_review

    Upon tracing the issue to this plugin, we’ve not had time to debug further and have just disabled the plugin for now.

    Not sure if this is a known issue?

Viewing 10 replies - 1 through 10 (of 10 total)
  • Plugin Author Raul P.

    (@alignak)

    Hi,

    Usually 403 happens when your server or wordpress blocks you out because of cookies or something similar, like you are logged in in the backend but not properly on the frontend.
    https://wordpress.org/support/topic/wc-ajaxupdate_order_review-403-error/

    Can you try to log out from wordpress and login again, to see if that happens still?
    Also did those errors stop completely, after you disabled FVM?

    And if yes, can you please test this version and see if it works?
    removed url

    If that works, you don’t need to do anything else.
    That will be 2.8.8 anyway.

    I added some extra data to the merging process, so I guess some sessions may be cached now causing that. Let me know if the above fixes anything. Thanks you

    Thread Starter George

    (@subscriptiongroup)

    The issue affects customers who are about to place an order and are therefore not logged in.

    It also started after one of today’s updates of this plugin so it’s not related to the suggestions shown on that link.

    I tried v2.8.8 and that didn’t help. In fact, it made things worse as Woocommerce Address Validation is not loading at all. Using the previous version, the “find address” button was shown.

    Plugin Author Raul P.

    (@alignak)

    Thank you.

    Sorry today there were several updates to solve a few other issues.

    Can you please confirm that 2.8.4 works, but not 2.8.5 ?

    https://downloads.wordpress.org/plugin/fast-velocity-minify.2.8.4.zip
    https://downloads.wordpress.org/plugin/fast-velocity-minify.2.8.5.zip

    You can go further back by replacing 2.8.x with older/newer versions.
    Thanks again

    Thread Starter George

    (@subscriptiongroup)

    Thanks for sending those across. It is actually 2.8.6 that’s not working. 2.8.5 and earlier versions work fine.

    Strangely i don’t have any errors on my logs

    Plugin Author Raul P.

    (@alignak)

    There are only a 2 lines change from 2.8.4 to 2.8.6 that may have affected this.

    This change is related to merging of $wp_scripts->registered[$handle]->extra['data'] which was introduced on 2.8.6.

    Sorry to bother you again, but can you please test if this one works?
    https://f001.backblazeb2.com/file/fvm-share/fast-velocity-minify.2.8.8.zip

    I believe it should work.
    Thanks again

    Hello Raul vs George,

    Sorry for interrupting this conversation!!!

    I have not found the cause. But versions 2.8.4 and 2.8.8 work well.

    When I use versions 2.8.6 and 2.8.7, some javascript scripts do not work properly.

    Some of my clients reported a few hours ago…

    I had to advise them to temporarily remove FVM.

    I have compared, this is the change between versions 2.8.7 and 2.8.8:

    https://imgur.com/a/sNlsleP

    Perhaps it is the cause, because after minify js, I cannot debug because the code is very long and difficult to read.

    I have advised hundreds of my customers to use FVM. Perhaps they are having some trouble this evening …

    Thanks!

    Plugin Author Raul P.

    (@alignak)

    @beeteam368 thanks for confirming. Version 2.8.8 is now live.

    Sorry about that, I pushed too many updates today trying to fix few different things reported by another user.

    Hello Raul,

    We found FVM to work well with WP Fastest Cache.

    Therefore, in the past 1 year. We have combined FVM with WP Fastest Cache.

    This is really a great acceleration solution when used with Cloudflare.

    Please calmly handle, maybe my problem is not like George’s …

    However, when I installed version 2.8.8, everything worked fine. The javascript script works properly.

    Thanks!

    Thread Starter George

    (@subscriptiongroup)

    The new 3.8.8 works for us also. I’ll keep an eye for any 403s and will report back if i come across any. Thanks for the prompt replies

    • This reply was modified 2 years, 1 month ago by George.

    2.8.6 was causing 403 on Woocommerce checkout page, preventing users to finish the order.

    2.8.8 fixed that issue.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Latest updates causing 403’ is closed to new replies.