Support » Plugin: Cloudflare » Latest update will not update

Viewing 7 replies - 1 through 7 (of 7 total)
  • Hi,

    What version of PHP are you running? Are there any errors in the PHP error log?

    We’re releasing a new major version of the plugin soon and were testing our new deployment scripts by rereleasing 1.3.24 as 1.3.25. There are no changes between those releases.

    Thanks,
    John

    Moderator Stephen Edgar

    (@netweb)

    I’m running PHP 7, and am unable to SSH into my server for a couple of hours, I’ll do that and report any errors back later today.

    It’s pretty clear your deployment scripts are broken, testing or not, see the changesets I linked to in my original post.

    Moderator Stephen Edgar

    (@netweb)

    I’ve no idea why, but having just SSH’d into my server the log files showed nothing related. So I’d thought I’d click update again and I would be able to see the latest log entries from tailing all the logs, clicked update, update worked this time /shrug

    I’ll close this as resolved but you should bump Compatible up to: 4.1.13 to Compatible up to: 4.6 if you believe it works with 4.6.

    And double check those deploy scripts because you should not be tagging ~30 versions each time you update the plugin on plugins.svn.wordpress.org

    Thanks! Agreed – the next version of the plugin has updated compatibility information for both the WordPress version and the PHP version.

    Moderator Stephen Edgar

    (@netweb)

    Please, also fix your deploy scripts, they should *not* be doing what they are doing.

    The docs here on “Tagging a new version” should help with that:

    How to Use Subversion

    Moderator Ipstenu (Mika Epstein)

    (@ipstenu)

    🏳️‍🌈 Plugin Review Team Rep

    @jwineman – netweb’s right.

    While you certainly can update existing tags, the only reason to do so is if you’re back porting patches (which … you’re not). Your script is goofed somewhere.

    https://plugins.trac.wordpress.org/changeset/1496517/ is showing that you’ve updated MOST of your tags. That’s actually a really REALLY bad thing, as it’s causing our servers to rebuild ALL OF YOUR VERSIONS. That’s a lot of zip building 🙂 Can you please fix that before we have to send a formal “Please stop system abuse” email?

    Hey,

    Yeah we’ll be doing manual deploys until we have a chance to fix the scripts.

    Thanks,
    John

Viewing 7 replies - 1 through 7 (of 7 total)
  • The topic ‘Latest update will not update’ is closed to new replies.