Support » Plugin: Complianz - GDPR/CCPA Cookie Consent » Latest update seems to break Jetpack stats

Viewing 15 replies - 1 through 15 (of 29 total)
  • Plugin Author Rogier Lankhorst

    (@rogierlankhorst)

    The update included a fix for the JetPack statistics tracking, as per this thread:
    https://wordpress.org/support/topic/jetpack-stats-13/

    As JetPack statistics require consent for the GDPR, users have to consent to tracking by statistics by accepting the statistics category.

    If you do not want this feature, you can disable the integration in the complianz/integrations/plugins.

    This will deactivate the integration, and JetPack will track without any interference.

    Thread Starter torstensbuechereckede

    (@torstensbuechereckede)

    Hi, I don’t think that it’s just that. Even if consent is activated there are no statistics for the user. Even if I completely deactivate complianz Jetpack statistics are not coming back. They are completely deactivated.

    Edit: What I have written seems to be only particualary true. I have deactivated Jetpack integration in Complianz and testet with curl but this was not recorded. But now some hits referred by google are showing up. This looks like more or less my tests setup with curl did not work.

    Im having the same issue. i have had no jetpack stats since updated. i also disabled the integration and still nothing.

    Plugin Contributor Aert Hulsebos

    (@aahulsebos)

    Hi @dfounde,

    Could you post your URL, so we can see what happens after consent?

    regards Aert

    Hi.
    It’s https://thenortherndad.co.uk

    I had deferred jquery to the footer and all was well. Obviously complianz requires this, so removed jquery from footer.

    I’ve disabled jet pack integration and cleared my cache. It now works.

    But if I enable the integration, clear my cache even if I accept all cookies jp stats don’t work.

    Jetpack stats stopped recording for me from the Complianz update on 1st Feb. If I deactivate Complianz they start working again.
    In terms of recording stats, Google Analytics is still working fine.

    Plugin Contributor Aert Hulsebos

    (@aahulsebos)

    Hi @tobeycat, @dfounde, @torstensbuechereckede,

    I tested this locally, and it seems to work;

    What it does; it sets the sources for JetPack stats to:

    <script type="text/plain" class="cmplz-script cmplz-stats" src="https://stats.wp.com/e-202106.js" defer=""></script>

    After consent on cmplz-stats, it will trigger to:

    <script type="text/javascript" class="cmplz-script cmplz-stats" src="https://stats.wp.com/e-202106.js" defer=""></script>

    Whereby the script source again is available and is tracking normally on my system.

    Is there anyone who would be able to enable the integration, so we can have a look?

    regards Aert

    I’ve re integrated mine. But will turn it back off at 4pm GMT

    Re enabled jet pack plugin within compliance and cleared cache…

    Just quickly tested and not stats recorded..

    I’ll turn it back off at 4pm GMT.

    Hi Aert (@aahulsebos)
    Thanks, but I don’t know how to do that 🙁

    Plugin Contributor Leon Wimmenhoeve

    (@leonwimmenhoeve)

    Hi @tobeycat,

    You can do this via Complianz -> integrations -> services -> Jetpack.

    Kind regards,
    Leon

    Hi @leonwimmenhoeve Thank you.
    When I go to ‘Complianz -> integrations -> services -> Jetpack’ jetpack isn’t listed in the Services tab. I can see it under the Plugins tab where ‘Connected’ and ‘Placeholder active’ are both toggled on.
    Is there anything else I need to do or change?

    Is there any more info on this? Jetpack stats still not working. Is what I’ve done (in previous comment) correct? @leonwimmenhoeve
    Thanks

    Plugin Contributor jarnovos

    (@jarnovos)

    Hi @tobeycat,

    When you have the Jetpack integration enabled, the script that is responsible for tracking the Jetpack statistics is blocked before user consent.

    You could disable the integration with Jetpack (Complianz > Integrations > Plugins) and it should work like it used to, but this effectively marks the script as “functional”.

    Hope this clarifies,
    Jarno

    Hi @jarnovos thanks for the response. My problem is that I don’t really understand what I’m supposed to do, e.g. when you say ‘disable the integration’. When I look in plugins I have Jetpack as ‘Connected’ and ‘Placeholder active’. When you say ‘disable the integration’ do you mean to switch the two toggles for these options to ‘off’?

    My second question is: do the comments above from rogierlankhorst mean that marking JetPack as functional rather than as marketing is misleading in the context of GDPR… so it is better to keep it connected under Complianz > Integrations > Plugins?

    Thanks again for your help.

Viewing 15 replies - 1 through 15 (of 29 total)
  • The topic ‘Latest update seems to break Jetpack stats’ is closed to new replies.