Support » Plugin: Relevanssi - A Better Search » Latest update not working

  • Resolved jazi58

    (@jazi58)


    After installing the latest update my website crashed – just a blank screen – so I uninstalled Relevanssi through FTP and then reinstalled it. Now the plugin will not activate and the following messages appear:

    Plugin could not be activated because it triggered a fatal error.

    Parse error: syntax error, unexpected T_STRING in /home3/thoroug4/public_html/wp-content/plugins/relevanssi/lib/indexing.php on line 120

    I love this plugin so can you please fix this problem asap as we use it a lot.

Viewing 6 replies - 1 through 6 (of 6 total)
  • Plugin Author Mikko Saari

    (@msaari)

    I’m running 3.5.9.1 on several of my sites, with no syntax errors involved. There have been issues with the plugin repository – perhaps you’ve been hit with a corrupt plugin file?

    I just downloaded the file from WordPress.org and installed the plugin on my site, and there are no errors. This file definitely works, maybe reinstalling from this file gets rid of the error: https://www.dropbox.com/s/z6qgcwl49usq5yr/relevanssi.3.5.9.1.zip?dl=0

    Thread Starter jazi58

    (@jazi58)

    Hi Mikko,

    Thanks very much for your prompt response. I tried to install the plugin with the zipfile you sent but I’m still getting the same error messages.

    Do you have any other suggestions?

    Kind regards,
    Sandy

    Plugin Author Mikko Saari

    (@msaari)

    That’s strange. Well, you could always edit the lib/indexing.php and simply remove the whole line 120. It should be this line:

    if ( defined( 'WP_CLI' ) && WP_CLI ) $progress = \WP_CLI\Utils\make_progress_bar( 'Indexing posts', count($content) );

    If you remove this line, does the plugin then work?

    Thread Starter jazi58

    (@jazi58)

    Hi again Mikko,

    I upgraded our php to 7 and the plugin has now activated.

    Thanks for your help.

    Sandy

    Plugin Author Mikko Saari

    (@msaari)

    Which version of PHP were you running before?

    Thread Starter jazi58

    (@jazi58)

    5.6.29

Viewing 6 replies - 1 through 6 (of 6 total)
  • The topic ‘Latest update not working’ is closed to new replies.