Support » Plugin: WooCommerce CardPointe Payment Gateway » Latest Update iFRAME API broke Credit Card number

  • Resolved ccolotti

    (@ccolotti)


    This was working fine and I think there was an update or something else it broken with Card Connect’s API but the CC field frame is failing to load:

    2020-07-16_17-00-34.png

    If I disable the iFRAME API option it seems to come back. Honestly the non iFRAME API looks better, but I thought we were asked to move to the other one. Either way this isn’t making a call just to load this field

    this seems odd:

        <p data-saved_hidden="true" class="form-row form-row-wide validate-required">
            <label for="card_connect-card-number">
    			Card Number            <span class="required">*</span>
            </label>
    		            <iframe
                        width="100%"
                        style="margin-bottom: 0;"
                        id="card_connect-iframe"
                        
                        frameborder="0"
                        scrolling="no"
                 data-src="https://fts.cardconnect.com/itoke/ajax-tokenizer.html?&formatinput=true&tokenizewheninactive=true&inactivityto=500" class="lazyload" src="data:image/gif;base64,R0lGODlhAQABAAAAACH5BAEKAAEALAAAAAABAAEAAAICTAEAOw=="></iframe>
    		    </p>

    the source of that field is just garbage.

    The page I need help with: [log in to see the link]

Viewing 1 replies (of 1 total)
  • Thread Starter ccolotti

    (@ccolotti)

    Forget it read the trace and SMUSH lazay load was set for iFRAME’s removed that option and seems fine now.

Viewing 1 replies (of 1 total)
  • The topic ‘Latest Update iFRAME API broke Credit Card number’ is closed to new replies.