Support » Plugin: Gutenberg » Latest Update Generates an Error

  • VP

    (@studio500)


    Hi, just to let you know.
    I updated to to the latest Gutenberg 5.3.0 update and Immediately received the below fatal error, which appears to be linked to a possible Elementor conflict.

    Fatal error: Uncaught Error: Call to undefined function Elementor\gutenberg_can_edit_post_type() in /home/bisfhous/public_html/wp-content/plugins/elementor/includes/compatibility.php:54 Stack trace: #0 /home/bisfhous/public_html/wp-includes/class-wp-hook.php(286): Elementor\Compatibility::add_new_button_to_gutenberg(”) #1 /home/bisfhous/public_html/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(”, Array) #2 /home/bisfhous/public_html/wp-includes/plugin.php(465): WP_Hook->do_action(Array) #3 /home/bisfhous/public_html/wp-admin/admin-header.php(120): do_action(‘admin_print_scr…’) #4 /home/bisfhous/public_html/wp-admin/edit.php(353): require_once(‘/home/bisfhous/…’) #5 {main} thrown in /home/bisfhous/public_html/wp-content/plugins/elementor/includes/compatibility.php on line 54

    • This topic was modified 1 year, 7 months ago by VP.
Viewing 10 replies - 1 through 10 (of 10 total)
  • Same here.

    I get “This block has encountered an error and cannot be previewed” When I try to add an image block!

    • This reply was modified 1 year, 7 months ago by danv19.

    Me pasa lo mismo

    • This reply was modified 1 year, 7 months ago by belicho.
    VP

    (@studio500)

    I have received an update from the Github developers of Gutenberg

    Reply states:

    yes gutenberg_can_edit_post_type is a plugin function and not something that is available in Core. I suggest and it was deprecated two releases ago (in the plugin). I suggest reaching out to Elementor.

    Thanks.

    Same problem here. Any solutions? We have to ask Elementor how to resolve?

    I got this same problem and managed to solve it by disabling the Gutenberg plugin (and working only with the version included in wp core)

    I did the same. Unfortunately that is only a workaround. I have really come to enjoy the Gutenberg Editor. I am sure they will have it fixed soon. đŸ™‚

    I did the same. Unfortunately that is only a workaround. I have really come to enjoy the Gutenberg Editor.

    Just to clarify, this error is not being caused by Gutenberg itself (which is part of WordPress core in WordPress 5.0+) but by the Gutenberg plugin.

    If you are using a version of WordPress 5 or above you do NOT need to have the Gutenberg plugin enabled to be using it.

    In fact on WordPress 5+ what the Gutenberg the plugin does is it allows you to test the most recent “Beta” version, but it is not required at all.

    I hope that helped. Cheers!

    • This reply was modified 1 year, 7 months ago by MrFoxTalbot.

    You could say that this is an obsolete Plugin, since the function has been moved to WordPress core. I can’t think of a situation where anyone would need the Plugin version.

    I may be mistaken but it is my understanding that if you keep the Gutenberg plugin it will load a “beta” version of Gutenberg, that is, the newest available version.

Viewing 10 replies - 1 through 10 (of 10 total)
  • The topic ‘Latest Update Generates an Error’ is closed to new replies.