Support » Plugin: BlockMeister - Block Pattern Builder » Latest Update – causing Error in Block Editor

  • Resolved stevieboy23

    (@stevieboy23)


    Hi, Firstly I love your plugin. Absolutely. I have spent the last month merrily creating block patterns for use on a Scottish healthcare websites. A brilliant tool to help non-designer end users.

    However, just updated to latest .05 version, but had to reinstall .04 version. It is causing an error in block editor whenever I click on the pattern inserter.

    I copied the error and here it is:

    TypeError: Cannot read property 'name' of undefined
        at https://***************/wp-includes/js/dist/block-editor.min.js?ver=ee2642fa39827fa8f0de00446089caf1:12:208356
        at Array.filter (<anonymous>)
        at https://***************/wp-includes/js/dist/block-editor.min.js?ver=ee2642fa39827fa8f0de00446089caf1:12:208310
        at Object.useMemo (https://***************/wp-includes/js/dist/vendor/react-dom.min.js?ver=16.13.1:216:441)
        at d.useMemo (https://***************/wp-includes/js/dist/vendor/react.min.js?ver=16.13.1:32:231)
        at Vl (https://***************/wp-includes/js/dist/block-editor.min.js?ver=ee2642fa39827fa8f0de00446089caf1:12:208288)
        at we (https://***************/wp-includes/js/dist/vendor/react-dom.min.js?ver=16.13.1:84:293)
        at zj (https://***************/wp-includes/js/dist/vendor/react-dom.min.js?ver=16.13.1:226:496)
        at Th (https://***************/wp-includes/js/dist/vendor/react-dom.min.js?ver=16.13.1:152:223)
        at tj (https://***************/wp-includes/js/dist/vendor/react-dom.min.js?ver=16.13.1:152:152)

    I had to blank out the web address as the site is still in development. Reverting back to previous version – all is well. Can you help?

    Many Thanks

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author BlockMeister

    (@blockmeister)

    Hi, I am glad you like the plugin 🙂

    I found and fixed a custom category related issue that is most likely the cause of the error you got.

    Could you please update to version 2.0.6 and let me know if it resolves the issue you reported?

    Thank you for reporting the issue!

    Thread Starter stevieboy23

    (@stevieboy23)

    Hello!

    Many thanks for the quick action – I am pleased to say all up and running again for 2.0.6, no problem now.

    Very Best Wishes

    Plugin Author BlockMeister

    (@blockmeister)

    You’re welcome, glad the problem is solved.
    Thank you for your review, much appreciated 😉
    Best wishes!

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.