Support » Plugin: WP-FormAssembly » Latest update caused a fatal error on our website?

  • Craig

    (@craigrkirkby)


    Hi There,

    The latest update caused a fatal error on our website. The only way we could get the website back up was by deleting the plugin.

    Still, we cannot access the website dashboard through the usual admin URL and get this message:

    Warning: fopen(/home/customer/www/xxxxxx.com/public_html/wp-content/plugins/formassembly-web-forms/wp_formassembly.php): failed to open stream: No such file or directory in /home/customer/www/xxxxxx.com/public_html/wp-includes/functions.php on line 6111

    Warning: Cannot modify header information – headers already sent by (output started at /home/customer/www/xxxxxx.com/public_html/wp-includes/functions.php:6111) in /home/customer/www/xxxxxx.com/public_html/wp-includes/pluggable.php on line 1329

    Please advise.

Viewing 14 replies - 1 through 14 (of 14 total)
  • Thread Starter Craig

    (@craigrkirkby)

    Update:

    I attempted to install the WP-FormAssembly plugin on a development site to test it and upon activating the plugin, I got this critical error:

    Warning: Use of undefined constant AUTOSAVE_INTERVAL - assumed 'AUTOSAVE_INTERVAL' (this will throw an Error in a future version of PHP) in /home/customer/www/xxxx.com/public_html/wp-includes/script-loader.php on line 1652
    
    Fatal error: Uncaught Error: Call to a member function using_index_permalinks() on null in /home/customer/www/xxxx.com/public_html/wp-includes/rest-api.php:403 Stack trace: #0 /home/customer/www/xxxx.com/public_html/wp-includes/rest-api.php(925): get_rest_url() #1 /home/customer/www/xxxx.com/public_html/wp-includes/class-wp-hook.php(290): rest_output_link_wp_head() #2 /home/customer/www/xxxx.com/public_html/wp-includes/class-wp-hook.php(316): WP_Hook->apply_filters(Array, Array) #3 /home/customer/www/xxxx.com/public_html/wp-includes/plugin.php(484): WP_Hook->do_action(Array) #4 /home/customer/www/xxxx.com/public_html/wp-content/plugins/formassembly-web-forms/wp_formassembly.php(35): do_action('wp_head', 'fa_referrer_hea...') #5 /home/customer/www/xxxx.com/public_html/wp-settings.php(391): include_once('/home/customer/...') #6 /home/customer/www/xxxx.com/public_html/wp-config.php(95): require_once('/home/customer/...') #7 /home/customer/www/xxxx.com/public_html/wp-load.php(37): in /home/customer/www/xxxx.com/public_html/wp-includes/rest-api.php on line 403
    There has been a critical error on this website. Please check your site admin email inbox for instructions.
    
    Learn more about troubleshooting WordPress.

    We also are getting a fatal error / white screen unless we disable the latest v2.0.5. I tried downloading and installing the prior version v2.0.4 manually moving the .zip file to the plugins folder but it was not recognized.

    “The latest update caused a fatal error on our website. The only way we could get the website back up was by deleting the plugin.”

    Same for one of my customers.

    Very poor quality work.

    Same issue as above. Reverted back to the previous version.

    Yep, same here. Do not install the update!!! Funny, it says this release only affected marketing stuff and no code changes….

    Had to roll back to a previous version that we had installed on another site that we moved over. Thank goodness for that!

    This new line is in the code:
    do_action( 'wp_head', 'fa_referrer_header');

    it should be

    add_action( 'wp_head', 'fa_referrer_header');

    SAME HERE! Even disabling all plugins, I’m still getting the same error for users who aren’t logged in, which makes me assume it’s just caching but I’ve cleared every g.d. cache known to man!!
    @stupidchief what file is that? I’m not seeing any do_action in wp_formassembly.php or whatever it’s called

    Same issue.

    The fix @stupidchief suggested is line 35 of wp_formassembly.php. I made the correction, and the plugin is no longer bringing down the site.

    If you need your website more than this plugin, just disabling the plugin and clearing all caches will do the trick. For me, that meant purging Cloudflare, SG Optimizer, Sucuri Firewall’s cache, And Siteground’s Dynamic Cache in Site Tools.

    If, like me, you can’t get into your wp-admin to disable plugins, go into your phpMyAdmin and open the wp_options table… actually, just follow the Siteground article’s instructions (same for all WordPress sites, no matter the host):
    https://www.siteground.com/kb/how_to_disable_all_wordpress_plugins_directly_from_database/

    Same thing happened to me last night with an auto-update on a client site. I didn’t even know this plugin was on their site and they didn’t remember having installed it, but it killed the entire site.

    I had to FTP in and just start moving plugins out of the plugins folder until I found the one that was causing the problem. Luckily I didn’t recognize this one so I tried it first. As soon as this was out of the plugins folder, everything was fine.

    The fix proposed by @stupidchief worked for me. If you decide to go this route, there is also a random “abc” string that appears at the top of the form. I’m guessing this was used as a test when this version of the plugin was created. If you want to remove this, go to line 117 of wp_formassembly.php and you’ll see $new_content = $style. 'abc' . $buffer; I removed abc and kept the ” just to make sure I didn’t break something.

    Killed our websites too even though the plugin was no longer in use. Fortunately we moved away from FA some time ago, so deletion was an option. See: wp_enqueue_scripts(‘fa_referrer_hea…’)

    WP_Hook->do_action(Array)\n#5 /nas/content/live/XXXXXXXXXXX/wp-includes/script-loader.php(2027): do_action('wp_enqueue_scri...')\n#6 /nas/content/live/XXXXXXXXXXX/wp-includes/class-wp-hook.php(292): wp_enqueue_scripts('fa_referrer_hea...')\n#7 /nas/content/live in /nas/content/live/XXXXXXXXXXX/wp-includes/capabilities.php on line 692

    Same issue here.

Viewing 14 replies - 1 through 14 (of 14 total)
  • The topic ‘Latest update caused a fatal error on our website?’ is closed to new replies.