Support » Plugin: Annual Archive » Latest update broke our sites

  • Resolved Shaun Robinson

    (@rubious)


    The latest update of this plugin broke 4 of our websites, the error message was:

    Fatal Error: Call to a member function get() on a non-object in wp-includes/query.php on line 28

    I had to remove the plugin to keep the sites working.

Viewing 15 replies - 16 through 30 (of 30 total)
  • @twinpictures
    sorry it’s me again. somehow the error came again and it has to do with overtime transient options. They were cleared and then the error came back

    Plugin Contributor twinpictures

    (@twinpictures)

    reopening issue.
    can you explain more about what

    overtime transient options

    is referring to?

    In order to understand where the issue is coming from, we need to be able to recreate it on our end, so as much detail as you can provide is appreciated.

    Plugin Contributor twinpictures

    (@twinpictures)

    @humpty2 can you share any details as to how to recreate this issue? When you say it broke your site, how exactly?

    Hi,
    these are temporary configurations.

    you can see them with this plugin:
    https://de.wordpress.org/plugins/transients-manager/

    the cooked plugin that is in conflict with your has an entry there about queries

    @twinpictures, I’m not sufficiently technical to know what happened! But I installed the first update and the site was gone. I replaced with original plugin and it came back. Same again with the latest update.

    I had the same problem as first reported on this thread with the latest version and tried the updated 1.5.1.
    Sadly I deleted the plugin for now but do hope to get it back once this issue is resolved.

    Plugin Contributor twinpictures

    (@twinpictures)

    For anyone that is having this issue:
    Please provide as much detail as you can. For example:
    Details about the hosting environment such as the PHP version
    Any errors that were displayed. How exactly the site broke.
    If you have a test environment, can you recreate the issue there?
    Does the issue go away when all other plugins are deactivated? IF so, which plugin is in conflict? The fact is we are not able to recreate the issue across a large number of WordPress installs… but we want to find out what the issue is and resolve it! Any one that is having this issue that is able to work with us to troubleshoot, please let us know here in the forum.

    In the meantime, if this issue is being experianced, please rollback to version 1.4.10 available for download here on WordPress.

    Thank you for your patience and understanding on this issue.

    Hi @twinpictures,

    Unfortunately, as my website is live, I cannot deactivate other plugins, but hope these steps of how I got the error might help:

    1. I first upgraded my WordPress installation to the latest version 4.9.4
    2. I clicked on the upgrade button in the plugins page for Annual Archive.
    3. After the upgrade was done, the dashboard became inaccessible and I got this error message: “Call to a member function get() on a non-object in wp-includes/query.php on line 28”
    4. The front-end of the website continued to work but it was only when I try to access the backend Dashboard I got the above error message.
    5. So I deleted the Annual Archive plugin from the plugins folder through FTP and the Dashboard was working again.
    6. I then found this thread so I tried version 1.5.1 recommended by downloading it and copying it to the plugins folders through FTP and the Dashboard was inaccessible again once I activated the plugin.

    WordPress version: 4.9.4
    PHP version 5.6
    Host: 1&1
    Wordpress Theme: WEXP Pronto theme

    Plugin Contributor twinpictures

    (@twinpictures)

    @hydardewachi
    If you are able, please download and test version 1.5.2a from GitHub and let us know if you continue to have issue.

    Since it’s a live site, it will be tricky to troubleshoot what exactly is causing the issue without some disruption.

    The recommended version of PHP for WordPress is now 7.2, so you might consider updating this as well – quite easy to do on 1&1.

    Thanks @twinpictures for the heads up re PHP version. I have just upgraded it to 7.2 and then tried version 1.5.1 to see if it was the PHP version that was the problem but got the below error, then uploaded and activated the new 1.5.2a version and got the same error message which has more details so I hope this helps you diagnose the problem.

    Fatal error: Uncaught Error: Call to a member function get() on null in /homepages/4/d448724373/htdocs/hydardewachi/wp-includes/query.php:28 Stack trace: #0 /homepages/4/d448724373/htdocs/hydardewachi/wp-content/plugins/annual-archive/annual_archive.php(86): get_query_var(‘decade’) #1 /homepages/4/d448724373/htdocs/hydardewachi/wp-includes/class-wp-hook.php(286): WP_Plugin_Annual_Archive->annual_archive_decade_filter(Object(WP_Query)) #2 /homepages/4/d448724373/htdocs/hydardewachi/wp-includes/class-wp-hook.php(310): WP_Hook->apply_filters(”, Array) #3 /homepages/4/d448724373/htdocs/hydardewachi/wp-includes/plugin.php(515): WP_Hook->do_action(Array) #4 /homepages/4/d448724373/htdocs/hydardewachi/wp-includes/class-wp-query.php(1634): do_action_ref_array(‘pre_get_posts’, Array) #5 /homepages/4/d448724373/htdocs/hydardewachi/wp-includes/class-wp-query.php(3230): WP_Query->get_posts() #6 /homepages/4/d448724373/htdocs/hydardewachi/wp-includes/post.php(1704): WP_Query->query(Array) #7 /homepages/4/d448724373/htdocs/hydardewach in /homepages/4/d448724373/htdocs/hydardewachi/wp-includes/query.php on line 28

    Plugin Contributor twinpictures

    (@twinpictures)

    Thank you. I think we got it figured out!
    Please try version 1.5.2b available from GitHub.
    Fairly confident this will resolve the issue. Let us know and we’ll push the update out today.
    Thanks for your patience and feedback!

    Thanks @twinpictures, this has definitely resolved it. Thank you for your hard work.

    Plugin Contributor twinpictures

    (@twinpictures)

    great! Just pushed the update for version 1.5.2
    Issue marked (finally) as resolved.

    Yes, it works. Thanks

    Edit: Nevermind, fixed the issue

    • This reply was modified 1 year, 4 months ago by rpsandiego.
    • This reply was modified 1 year, 4 months ago by rpsandiego. Reason: incorrect URL provided
    • This reply was modified 1 year, 4 months ago by rpsandiego.
Viewing 15 replies - 16 through 30 (of 30 total)
  • The topic ‘Latest update broke our sites’ is closed to new replies.