Support » Plugin: Advanced Editor Tools (previously TinyMCE Advanced) » Latest update broke my icons

  • TinyMCE Advanced 4.8.1 contain file wp-content/plugins/tinymce-advanced/block-editor/block-editor.css at the line 262 with this code.

    .editor-styles-wrapper .wp-block[data-type="core/freeform"] .mce-toolbar-grp .mce-btn i {
        font-family: tinymce !important;
    }

    This CSS override my custom icons (I’m using FontAwesome icons) that is needed font-family: "FontAwesome";

    Please **do not** override other plugin’s icons.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Andrew Ozz

    (@azaozz)

    Uh, this is a (temporary) fix for https://github.com/WordPress/twentynineteen/issues/719. The bug there overrides all button icons, including the TinyMCE defaults. Will remove it as soon as the above is fixed in Twenty Nineteen.

    • This reply was modified 1 year, 11 months ago by Andrew Ozz.
    Plugin Author Andrew Ozz

    (@azaozz)

    Actually I should be able to apply that dreaded !important only to the default TinyMCE buttons. Fix will be in the next update. That will leave the Twenty Nineteen bug that will still override any other icons. You will probably have to add the !important to your custom icons for now too 🙁

    😀 Thank you. I will leave that until fixed, I don’t want override others too.

Viewing 3 replies - 1 through 3 (of 3 total)
  • The topic ‘Latest update broke my icons’ is closed to new replies.