Support » Plugin: Permalink Manager Lite » Latest update breaks UTF-8 permalinks

  • Resolved keysuck

    (@keysuck)



    Permalinks containing UTF-8 characters are displayed in the form of latin characters, instead (example: %AE%DK%99) across all major browsers (Chrome, IE, Firefox) and causes 404 errors and/or too many redirects. Disabling the plugin resolves the issue. Has anything changed in the latest update(s)?

Viewing 11 replies - 1 through 11 (of 11 total)
  • Plugin Author Maciej Bis

    (@mbis)

    Hi @keysuck,

    could you send me a sample permalink to my email address contact /at/ maciejbis.net?

    Best regards,
    Maciej

    Plugin Author Maciej Bis

    (@mbis)

    Hi again @keysuck,

    you can disable “Encode URI” function using this little code snippet (please paste it to child theme functions.php file):

    function pm_decode_uris($options) {
    	if(!empty($options['general'])) {
    		$options['general']['decode_uris'] = true;
    	}
    
    	return $options;
    }
    add_filter('permalink-manager-options', 'pm_decode_uris');

    Best regards,
    Maciej

    Hello Maciej,

    I inserted the code snippet in the child them’s functions.php per your instruction but the problem still persists (TOO MANY REDIRECTS).

    • This reply was modified 1 month, 1 week ago by  keysuck.
    • This reply was modified 1 month, 1 week ago by  keysuck.
    Plugin Author Maciej Bis

    (@mbis)

    Hi @keysuck,

    could you try to disable “Canonical redirect” in Permalink Manager settings?

    Best regards,
    Maciej

    The problem persists. Disabling the plugin resolves the issue, unfortunately.

    Plugin Author Maciej Bis

    (@mbis)

    Hi @keysuck,

    please send me the sample URL where the redirect loop persists.

    Best regards,
    Maciej

    Thanks. Since I am working on the backend part, you can visit http://www.instruments.kr and click on any of the products on the front page, or inside WooCommerce shop.

    Plugin Author Maciej Bis

    (@mbis)

    It looks like your custom URIs are double-encoded. Please add one more snippet:

    function pm_decode_uris($permalink) {
    	return urldecode(urldecode($permalink));
    }
    add_filter('permalink_manager_filter_final_post_permalink', 'pm_decode_uris');
    add_filter('permalink_manager_filter_final_term_permalink', 'pm_decode_uris');

    Thanks. However, the additional snippet causes HTTP ERROR 500 and disables access to the domain and all subdomains.

    Plugin Author Maciej Bis

    (@mbis)

    Hi @keysuck,

    could you provide me with FTP access to wp-content/plugins/permalink-manager directory. If so, please send me the credentials via email.

    Best regards,
    Maciej

    keysuck

    (@keysuck)

    Thanks for the remote assistance.
    I have translated the plugin into Korean and updated on Glotpress in appreciation for your support.

Viewing 11 replies - 1 through 11 (of 11 total)
  • You must be logged in to reply to this topic.