Support » Plugin: Permalink Manager Lite » Latest update breaks the permalink functionality

  • Resolved baxterip


    I’ve been using the lite version of the plugin prior to the latest updates over this weekend. After updating the plugin, it does not seem to do what it used to.

    Whenever I save the permalink via a page or post, either it gets the URI of the homepage and uses that, or it gets the URI of the parent pages (if available) and uses that (i.e. if parent pages are multiple pages, parent1/parent2/post-name, it always uses this regardless whether I save it).

    When I access it via the Permalink manager via bulk URI editor, it works (at least only at the time), but when I try to save again via the post/page editor, it reverts back to above issues.

    We are still currently developing our website so for now we are opting to use the lite version. Not sure if this is a lite vs pro feature, but prior to the update/s, the plugin was working as it was expected with no hitches.

Viewing 3 replies - 1 through 3 (of 3 total)
  • Plugin Author Maciej Bis


    Hi @baxterip,

    I apologize for the inconvenience. I am not certain what version of plugin did you use before the update, but last two updates included only minor changes to the functions responsible for saving the custom permalinks:

    I think that the problem you experience might be caused by the change I made in version. Since then, if “Auto-update permalinks” mode is enabled, the URI editor is disabled not only in post/page editor but also in bulk URI editor. At the same time, all the manual changes are overwritten with the default permalink if a single post/page is saved/updated.

    Could you check if “Auto-update permalinks” is turned on in the plugin settings? If not, the problem is somewhere else and I would like to investigate it further. My email address is contact /at/

    Best regards,

    • This reply was modified 2 months, 1 week ago by Maciej Bis.
    Thread Starter baxterip


    Hi @mbis, thanks for your response.

    I have already played around with different combinations of settings for the plugins to try and figure out what’s causing the bug.

    These are the current settings that I have:
    – Auto-update permalinks (turned off)
    – Slugs mode (use actual titles as slugs, previously set to use native slugs)
    – Remove trailing slashes
    – 301 Redirect
    – Force HTTPS/WWW
    – Trailing slashes redirect
    – WPML/Polylang language mismatch
    – Force 404

    One major thing I noticed is that whenever I save the URIs via the URI editor, it accepts the change, except until I click update again via the update permalink on post editor, which then reverts it to the parent-child URI structure.

    This bug, it seems, happens only specifically to non-alphabetical characters (specifically with simplified Chinese characters on URIs, for our multilanguage site), so it may have something to do with a third-party plugin, I suppose? Do you have any idea how to fix this?

    I also noticed that when saving a Chinese character onto the URI editor, then by accessing the link using HTML-encoded Chinese characters (i.e. %XX%XX), it doesn’t automatically redirect to the equivalent Chinese page, which originally supposedly does. With this, I think I’d have to manually redirect HTML-encoded URIs to Chinese character URIs via htaccess. But if you know of a fix that can solve this, I’d love to hear of it!

    Plugin Author Maciej Bis


    Hi @baxterip,

    Could you possibly provide me with temp. admin access to your test website?

    Best regards,

Viewing 3 replies - 1 through 3 (of 3 total)
  • You must be logged in to reply to this topic.