Support » Plugin: WP Offload S3 Lite » Latest Update Breaks it

  • Resolved dlynch027

    (@dlynch027)


    I just applied the latest update to my website and now I can no longer upload images.

    When trying to upload an image, it sits there for a while and then I get this error. . .

    Fatal error: Cannot use object of type WP_Error as array in /homepages/31/d584948166/htdocs/testappstoreapps/wp-includes/media.php on line 196

    https://wordpress.org/plugins/amazon-s3-and-cloudfront/

Viewing 15 replies - 1 through 15 (of 22 total)
  • I just reverted back to the last version, but I still can’t view my media library from within WordPress. It just sits there spinning as if it is loading, but never shows any images(been sitting here watching it for 5 minutes)

    This is happening for me too, the support tab wont work either now.

    Plugin Author Delicious Brains Inc.

    (@deliciousbrains)

    Are you able to check your postmeta table for a ‘_wp_attachment_metadata’ meta_key that contains a WP_Error message? If you could post back the contents of meta_value that would be appreciated.

    I got this

    O:8:"WP_Error":2:{s:6:"errors";a:1:{s:9:"exception";a:1:{i:0;s:122:"File /homepages/31/d584948166/htdocs/testappstoreapps/wp-content/uploads/Screenshot_2015-05-24-12-14-09.png does not exist";}}s:10:"error_data";a:0:{}}

    I am also getting this error with very similar WP_Error entries in my DB. I’ve also tried reverting to previous version without success

    as much as I hate the hassle that has come along with this, it’s good to know that I’m not alone. I’m in the process of trying to restore back from week’s old backups(losing dozens of posts) because I didn’t think I had to do a backup before applying such a (seemingly) small update to a plugin.

    I won’t make that mistake again. Hopefully the devs will be able to push out a fix for this soon though

    I literally can’t do anything with my websites because I can’t upload images or access the media library

    Same problem here but if I set the filter to just images it works fine, it seems to be when it has to load audio files that it gets stuck.

    Apparently Delicious Brains are no longer providing support on this forum (https://wordpress.org/support/topic/support-125) so if someone with a GitHub account could inform them of this bug I’m sure we’d all be very grateful.

    You can use this plugin to rollback to the previous version of Offload S3. https://wordpress.org/plugins/wp-rollback/

    I have already created a bug report on GitHub here

    https://github.com/deliciousbrains/wp-amazon-s3-and-cloudfront/issues/271

    So if everyone could go there to reply and report their bugs too, maybe the developers will have enough information to fix the bugs

    I have tried setting the filter to just images, and I still can’t get it to show them on my sites

    Okay, as a workaround to this error, I had to revert back to the old version of the ‘amazon-s3-and-cloudfront’ plugin. Then, I had to dive into phpmyadmin, head into the postmeta table and sort by post id. Making it so that it showed all of the newer entries in this table. Then I looked at all entries for the error that has been talked about here(the wp_error).

    Any post id entry that shared the same number as one with the wp error issue, I deleted. Then I went into the wordpress wp-admin section, looked at the library and it showed up, but with some images that couldn’t be displayed. I then clicked on each one and deleted it so that it was completely removed

    Once all this was done, I am now able to upload images and the plugin(with the last version, not the new version) will send, host and display these images from my Amazon AWS bucket, and now I can see all of my stuff from the library

    This isn’t a fix, just a workaround that I discovered by fiddling around and trying different things out. Hopefully the developers will be able to find the root cause of the issue and fix it in a future update(positive thoughts)

    Thankyou! Do you have a link to a dropbox or something with the old version of the plugin? I cant get to a machine with it on.

    cheers,

    Nick

    Plugin Author Delicious Brains Inc.

    (@deliciousbrains)

    We are working on a fix, but to cover all bases, can you post your diagnostic info please?

    So the fix for this has just been released as 0.9.5, let us know how that goes and thanks for your patience.

    Thanks for the update, this hasn’t fixed the problem with not being able to view the media library. I’ve made a little video to show you exactly what I’m seeing. If I filter by images then everything loads, any other option though and I see nothing.
    https://youtu.be/g5I2SElb9cI

    Hi Dave,

    Can you visit the S3 settings page, do you see an update notice about fixing corrupted metadata for attachments? If so, this will need to complete before the media library is viewable again.

Viewing 15 replies - 1 through 15 (of 22 total)
  • The topic ‘Latest Update Breaks it’ is closed to new replies.